new Windows build problem

Simon Peyton Jones simonpj at
Thu Mar 6 23:42:25 UTC 2014

Actually, the two problems seem to be the same.  A fresh build from scratch yields

libraries/random/ recipe for target 'libraries/random/dist-install/build/System/Random.o' failed

make[1]: *** [libraries/random/dist-install/build/System/Random.o] Segmentation fault
Then sniping the command line that tried to build Random.o yields

"inplace/bin/ghc-stage2.exe" -hisuf hi -osuf  o -hcsuf hc -static  -H32m -O -Werror -Wall -H64m -O0    -package-name random- -hide-all-packages -i -ilibraries/random/. -ilibraries/random/dist-install/build -ilibraries/random/dist-install/build/autogen -Ilibraries/random/dist-install/build -Ilibraries/random/dist-install/build/autogen -Ilibraries/random/.    -optP-include -optPlibraries/random/dist-install/build/autogen/cabal_macros.h -package base- -package time-1.4.2 -O2 -XHaskell98 -XCPP -O2 -O -dcore-lint -fno-warn-amp  -fno-warn-deprecated-flags -dcore-lint  -no-user-package-db -rtsopts      -odir libraries/random/dist-install/build -hidir libraries/random/dist-install/build -stubdir libraries/random/dist-install/build   -c libraries/random/./System/Random.hs -o libraries/random/dist-install/build/System/Random.o

bash: [6536: 1 (255)] tcsetattr: Inappropriate ioctl for device
So this ioctl thing seems to be reported as a seg fault by the make system.
Running the same command from a 'cmd' window does give a seg-fault pop-up window.  Alas.
Running with -dshow-passes shows that it happens during code generation,

*** CorePrep:

Result size of CorePrep = {terms: 1,214, types: 912, coercions: 52}

*** Core Linted result of CorePrep:

*** Stg2Stg:

*** CodeOutput:

*** New CodeGen:

*** CPSZ:

*** CPSZ:
I am totally stuck.
From: Simon Peyton Jones
Sent: 06 March 2014 22:11
To: ghc-devs at
Subject: new Windows build problem

Sigh.  Totally new problem with building GHC (HEAD) on Windows..

"inplace/bin/ghc-stage2.exe" -hisuf hi -osuf  o -hcsuf hc -static  -H32m -O -Werror -Wall -H64m -O0    -package-name haskell98- -hide-all-packages -i -ilibraries/haskell98/. -ilibraries/haskell98/dist-install/build -ilibraries/haskell98/dist-install/build/autogen -Ilibraries/haskell98/dist-install/build -Ilibraries/haskell98/dist-install/build/autogen -Ilibraries/haskell98/.    -optP-include -optPlibraries/haskell98/dist-install/build/autogen/cabal_macros.h -package array- -package base- -package directory- -package old-locale- -package old-time- -package process- -package time-1.4.2 -Wall -XHaskell98 -O2 -O -dcore-lint -fno-warn-amp  -fno-warn-deprecated-flags -dcore-lint  -no-user-package-db -rtsopts      -odir libraries/haskell98/dist-install/build -hidir libraries/haskell98/dist-install/build -stubdir libraries/haskell98/dist-install/build   -c libraries/haskell98/./Directory.hs -o libraries/haskell98/dist-install/build/Directory.o

bash: [6536: 1 (255)] tcsetattr: Inappropriate ioctl for device

What on earth is this ioctl stuff?
The above is repeatable; same command line, same result.

But I'm also getting random seg-faults when building libraries with the stage2 compiler

libraries/random/ recipe for target 'libraries/random/dist-install/build/System/Random.o' failed

make[1]: *** [libraries/random/dist-install/build/System/Random.o] Segmentation fault
This is NOT repeatable.  Saying 'make' again gets further.
Any ideas?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the ghc-devs mailing list