Overloaded record fields: we ought to change the name of FldTy
johan.tibell at gmail.com
Wed Apr 30 08:33:01 UTC 2014
I'm currently watching the Skills Matter talks you gave (great!) and I'm
slightly worried that we're going to expose beginners (and intermediate
users!) to a name called FldTy, which might be OK for a GHC-internal name,
but is not very readable.
If this is going to be exposed to users, could we name is something
readable, like FieldType, Field, or something similar?
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the ghc-devs