Building & running NoFib

Amos Robinson amos.robinson at
Fri May 10 00:36:22 CEST 2013

Hi all,

I've just tried running 'make' in nofib and it's not finding
../inplace/bin/ghc-stage2 for some reason. So it tries to execute
"/BLAH/ghc/ghc-head/" as if it were ghc (but it's a directory).

The error message is:
> /bin/sh: /Users/amos/ghc/ghc-head/: is a directory
> /bin/sh: line 0: [: -gt: unary operator expected
> /bin/sh: line 0: [: -ge: unary operator expected
> ...
> /Users/amos/ghc/ghc-head/ -H64m -O0 -fasm -O2 -Rghc-timing -package array
-H32m -hisuf hi -c Main.hs -o Main.omake[2]: /Users/amos/ghc/ghc-head/:
Permission denied

I tried on another box - Linux - and had much the same issue. Has anyone
seen this before? Any clues what might be wrong? Nofib was building fine on
the Linux box a few weeks ago, but I think it stopped working after a

For now though, I'll just try building with
> WithNofibHc=/Users/amos/ghc/ghc-head/inplace/bin/ghc-stage2 make
which seems to work.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the ghc-devs mailing list