Testsuite produces false failures?

Jan Stolarek jan.stolarek at p.lodz.pl
Wed Jan 16 19:25:51 CET 2013

Today I verified my patch and I got seven failures of the test suite, six of which were caused by 
changes in the fundeps (according to Simon's mail it should be fixed by now). So one was 
obviously caused by my patch. After validation has completed I run this one test again 
using "make TEST=name_of_test" and it passed without problems. After submiting my patch I rebased 
my branch with changes onto latest HEAD (which has changed while I was running previous 
validation) and I got 207 test failures. For example one of them is "2566" from driver directory. 
So I run "make TEST=2566" and get this:

cd ./driver && $MAKE -s --no-print-directory 2566    </dev/null >2566.run.stdout 2>2566.run.stderr

OVERALL SUMMARY for test run started at śro, 16 sty 2013, 19:11:02 CET
    3576 total tests, which gave rise to
   14254 test cases, of which
       0 caused framework failures
   14253 were skipped

       1 expected passes
       0 had missing libraries
       0 expected failures
       0 unexpected passes
       0 unexpected failures

Also, running the command being tested manually on the stage 2 binary gives correct result:

[killy at xerxes : /dane/uczelnia/projekty/ghc-validate/inplace/bin] ./ghc-stage2 -c foo2566.bar
Warning: the following files would be used as linker inputs, but linking is not being done: 
ghc-stage2: no input files
Usage: For basic information, try the `--help' option.

Can someone give me a hint what is going on?


More information about the ghc-devs mailing list