No instance for (Fractional Int32)

Gabor Greif ggreif at
Sat Feb 9 08:00:46 CET 2013

On 2/8/13, Christopher Vollick <0 at> wrote:
> On Fri, Feb 08, 2013 at 01:20:53PM +0100, Gabor Greif wrote:
>> libraries/base/Foreign/C/Types.hs:162:72:
>>     No instance for (Fractional Int32)
>>       arising from the 'deriving' clause of a data type declaration
>>     Possible fix:
>>       use a standalone 'deriving instance' declaration,
>>         so you can specify the instance context yourself
>>     When deriving the instance for (Fractional CFloat)
>> Has anybody seen this with HEAD?
> Yeah, I have.
> I was going to look into why, but then I forgot.
> I worked around it by going into libraries/base and running ./configure
> --target=whatever manually.
> Then, when I built it worked for some reason.
> Then, when building from the top again, it didn't rebuild base.
> If you wanted to figure out why, you have my blessing.

For the record, I fixed this with




> I'm assuming something gets passed down that shouldn't, or something.
> _______________________________________________
> ghc-devs mailing list
> ghc-devs at

More information about the ghc-devs mailing list