make -jN loops on Windows

Simon Peyton-Jones simonpj at
Wed Aug 28 09:52:22 CEST 2013

I tried make -j2, which locked up.  "sh validate" used -j but I'm not sure with what N.

It's tantalising if it worked for you!  And it worked fine on my old Win7 laptop.  Where did you get your mingw/msys installation from?  I got mine from, using the download installer "Mingw-get-setup.exe".

I have also just unravelled another bizarre failure, which I'll describe in a separate email.  Sadly resolving the latter does not fix the make -j2 problem.


From: ghc-devs [mailto:ghc-devs-bounces at] On Behalf Of Niklas Larsson
Sent: 27 August 2013 23:56
To: Kyle Van Berendonck
Cc: ghc-devs at
Subject: Re: make -jN loops on Windows


Are you using make -j with or without number of jobs? I tried with make -j4 on my Windows 8 machine and it worked well.


2013/8/27 Kyle Van Berendonck <kvanberendonck at<mailto:kvanberendonck at>>
Hi Simon,

I think this is a MinGW bug. If we're talking about the same bug (lockup, no console output, task manager shows cpu but it doesn't produce files, etc) I get it when building other projects with -j too and I don't think its GHC's fault.


Kyle Van Berendonck

ghc-devs mailing list
ghc-devs at<mailto:ghc-devs at>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the ghc-devs mailing list