Changes to primops break libraries (was Re: 7.8 Feature window)

Herbert Valerio Riedel hvr at
Mon Aug 26 12:51:56 CEST 2013

On 2013-08-26 at 10:56:15 +0200, Gregory Collins wrote:
> On Sun, Aug 25, 2013 at 9:47 PM, Simon Marlow <marlowsd at> wrote:
>> On 25/08/13 20:16, Jan Stolarek wrote:
>>> We really want people to use the new primops, not the wrappers
>>> We do? Could you justify why we want to people to use primops?
>> What I meant was, if people are already using primops we want them to use
>> the new ones instead.
> Please don't just break existing code!

...btw, do we actually know which (or how many) packages are affected?

More information about the ghc-devs mailing list