[Git][ghc/ghc][master] fix: Update documentation links

Marge Bot (@marge-bot) gitlab at gitlab.haskell.org
Wed Feb 22 04:59:02 UTC 2023



Marge Bot pushed to branch master at Glasgow Haskell Compiler / GHC


Commits:
f11d9c27 by romes at 2023-02-21T23:58:42-05:00
fix: Update documentation links

Closes #23008

Additionally batches some fixes to pointers to the Note [Wired-in units],
and a typo in said note.

- - - - -


3 changed files:

- compiler/GHC/Unit.hs
- compiler/GHC/Unit/State.hs
- docs/users_guide/exts/deriving_strategies.rst


Changes:

=====================================
compiler/GHC/Unit.hs
=====================================
@@ -63,7 +63,7 @@ Wired-in units
 
 Certain libraries (ghc-prim, base, etc.) are known to the compiler and to the
 RTS as they provide some basic primitives.  Hence UnitIds of wired-in libraries
-are fixed. Instead of letting Cabal chose the UnitId for these libraries, their
+are fixed. Instead of letting Cabal choose the UnitId for these libraries, their
 .cabal file uses the following stanza to force it to a specific value:
 
    ghc-options: -this-unit-id ghc-prim    -- taken from ghc-prim.cabal


=====================================
compiler/GHC/Unit/State.hs
=====================================
@@ -1078,7 +1078,7 @@ pprTrustFlag flag = case flag of
 -- -----------------------------------------------------------------------------
 -- Wired-in units
 --
--- See Note [Wired-in units] in GHC.Unit.Module
+-- See Note [Wired-in units] in GHC.Unit.Types
 
 type WiringMap = Map UnitId UnitId
 
@@ -1094,7 +1094,7 @@ findWiredInUnits
 findWiredInUnits logger prec_map pkgs vis_map = do
   -- Now we must find our wired-in units, and rename them to
   -- their canonical names (eg. base-1.0 ==> base), as described
-  -- in Note [Wired-in units] in GHC.Unit.Module
+  -- in Note [Wired-in units] in GHC.Unit.Types
   let
         matches :: UnitInfo -> UnitId -> Bool
         pc `matches` pid = unitPackageName pc == PackageName (unitIdFS pid)
@@ -1177,7 +1177,7 @@ findWiredInUnits logger prec_map pkgs vis_map = do
 
 -- Helper functions for rewiring Module and Unit.  These
 -- rewrite Units of modules in wired-in packages to the form known to the
--- compiler, as described in Note [Wired-in units] in GHC.Unit.Module.
+-- compiler, as described in Note [Wired-in units] in GHC.Unit.Types.
 --
 -- For instance, base-4.9.0.0 will be rewritten to just base, to match
 -- what appears in GHC.Builtin.Names.


=====================================
docs/users_guide/exts/deriving_strategies.rst
=====================================
@@ -70,7 +70,7 @@ If an explicit deriving strategy is not given, multiple strategies may apply.
 In that case, GHC chooses the strategy as follows:
 
 1. Stock type classes, i.e. those specified in the report and those enabled by
-   `language extensions <#deriving-extra>`__, are derived using the ``stock``
+   :ref:`language extensions <deriving-extra>`, are derived using the ``stock``
    strategy, with the following exception:
 
    * For newtypes, ``Eq``, ``Ord``, ``Ix`` and ``Bounded`` are always derived
@@ -82,7 +82,7 @@ In that case, GHC chooses the strategy as follows:
      using the ``newtype`` strategy if ``GeneralizedNewtypeDeriving`` is
      enabled and the derivation succeeds.
 
-2. For other any type class:
+2. For any other type class:
 
    1. When :extension:`DeriveAnyClass` is enabled, use ``anyclass``.
 



View it on GitLab: https://gitlab.haskell.org/ghc/ghc/-/commit/f11d9c274d728696bc173c62a2ead62b8288836f

-- 
View it on GitLab: https://gitlab.haskell.org/ghc/ghc/-/commit/f11d9c274d728696bc173c62a2ead62b8288836f
You're receiving this email because of your account on gitlab.haskell.org.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.haskell.org/pipermail/ghc-commits/attachments/20230221/22185128/attachment-0001.html>


More information about the ghc-commits mailing list