[Git][ghc/ghc][wip/js-staging] Primops: set dv_u8 to correct method call

doyougnu (@doyougnu) gitlab at gitlab.haskell.org
Wed Sep 7 16:50:42 UTC 2022



doyougnu pushed to branch wip/js-staging at Glasgow Haskell Compiler / GHC


Commits:
dcd89960 by doyougnu at 2022-09-07T12:49:25-04:00
Primops: set dv_u8 to correct method call

should be getUint8, not getUInt8, of course the naming convention
changes ever so slightly for Words.

- - - - -


1 changed file:

- compiler/GHC/StgToJS/Prim.hs


Changes:

=====================================
compiler/GHC/StgToJS/Prim.hs
=====================================
@@ -1287,7 +1287,7 @@ dv_s_f32 a i v = ApplStat (a .^ "dv" .^ "setFloat32") [i, v, true_]
 dv_s_f64 a i v = ApplStat (a .^ "dv" .^ "setFloat64") [i, v, true_]
 
 dv_i8, dv_u8, dv_i16, dv_u16, dv_i32, dv_u32, dv_f32, dv_f64 :: JExpr -> JExpr -> JExpr
-dv_u8  a i = ApplExpr (a .^ "dv" .^ "getUInt8"   ) [i, true_]
+dv_u8  a i = ApplExpr (a .^ "dv" .^ "getUint8"   ) [i, true_]
 dv_i8  a i = ApplExpr (a .^ "dv" .^ "getInt8"   ) [i, true_]
 dv_i16 a i = ApplExpr (a .^ "dv" .^ "getInt16"  ) [i, true_]
 dv_u16 a i = ApplExpr (a .^ "dv" .^ "getUint16" ) [i, true_]



View it on GitLab: https://gitlab.haskell.org/ghc/ghc/-/commit/dcd899606f29756be62d87f6a3a0a61602f28b78

-- 
View it on GitLab: https://gitlab.haskell.org/ghc/ghc/-/commit/dcd899606f29756be62d87f6a3a0a61602f28b78
You're receiving this email because of your account on gitlab.haskell.org.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.haskell.org/pipermail/ghc-commits/attachments/20220907/5cec7b4b/attachment.html>


More information about the ghc-commits mailing list