[commit: ghc] master: Rename some mutable closure types for consistency (4075656)

git at git.haskell.org git at git.haskell.org
Tue Jun 5 14:02:04 UTC 2018


Repository : ssh://git@git.haskell.org/ghc

On branch  : master
Link       : http://ghc.haskell.org/trac/ghc/changeset/4075656e8bb2338d9857acfa54f8b9c5e0661f44/ghc

>---------------------------------------------------------------

commit 4075656e8bb2338d9857acfa54f8b9c5e0661f44
Author: Ömer Sinan Ağacan <omeragacan at gmail.com>
Date:   Tue Jun 5 17:00:22 2018 +0300

    Rename some mutable closure types for consistency
    
    SMALL_MUT_ARR_PTRS_FROZEN0 -> SMALL_MUT_ARR_PTRS_FROZEN_DIRTY
    SMALL_MUT_ARR_PTRS_FROZEN  -> SMALL_MUT_ARR_PTRS_FROZEN_CLEAN
    MUT_ARR_PTRS_FROZEN0       -> MUT_ARR_PTRS_FROZEN_DIRTY
    MUT_ARR_PTRS_FROZEN        -> MUT_ARR_PTRS_FROZEN_CLEAN
    
    Naming is now consistent with other CLEAR/DIRTY objects (MVAR, MUT_VAR,
    MUT_ARR_PTRS).
    
    (alternatively we could rename MVAR_DIRTY/MVAR_CLEAN etc. to MVAR0/MVAR)
    
    Removed a few comments in Scav.c about FROZEN0 being on the mut_list
    because it's now clear from the closure type.
    
    Reviewers: bgamari, simonmar, erikd
    
    Reviewed By: simonmar
    
    Subscribers: rwbarton, thomie, carter
    
    Differential Revision: https://phabricator.haskell.org/D4784


>---------------------------------------------------------------

4075656e8bb2338d9857acfa54f8b9c5e0661f44
 compiler/cmm/CLabel.hs                           | 21 ++++----
 compiler/codeGen/StgCmmPrim.hs                   | 16 +++---
 includes/rts/storage/ClosureMacros.h             |  8 +--
 includes/rts/storage/ClosureTypes.h              |  8 +--
 includes/stg/MiscClosures.h                      |  8 +--
 libraries/ghc-heap/GHC/Exts/Heap.hs              |  2 +-
 libraries/ghc-heap/GHC/Exts/Heap/ClosureTypes.hs |  8 +--
 rts/CheckUnload.c                                |  8 +--
 rts/ClosureFlags.c                               | 12 ++---
 rts/Compact.cmm                                  |  8 +--
 rts/Heap.c                                       |  6 +--
 rts/LdvProfile.c                                 |  8 +--
 rts/PrimOps.cmm                                  | 37 +++++---------
 rts/Printer.c                                    | 16 +++---
 rts/ProfHeap.c                                   |  8 +--
 rts/RetainerProfile.c                            | 20 ++++----
 rts/RtsSymbols.c                                 |  8 +--
 rts/StgMiscClosures.cmm                          | 16 +++---
 rts/Weak.c                                       |  2 +-
 rts/sm/CNF.c                                     | 16 +++---
 rts/sm/Compact.c                                 | 16 +++---
 rts/sm/Evac.c                                    |  8 +--
 rts/sm/Sanity.c                                  |  4 +-
 rts/sm/Scav.c                                    | 64 ++++++++++--------------
 24 files changed, 152 insertions(+), 176 deletions(-)

Diff suppressed because of size. To see it, use:

    git diff-tree --root --patch-with-stat --no-color --find-copies-harder --ignore-space-at-eol --cc 4075656e8bb2338d9857acfa54f8b9c5e0661f44


More information about the ghc-commits mailing list