[commit: ghc] master: Remove unneeded import (7097f94)
git at git.haskell.org
git at git.haskell.org
Wed Jun 28 18:13:05 UTC 2017
Repository : ssh://git@git.haskell.org/ghc
On branch : master
Link : http://ghc.haskell.org/trac/ghc/changeset/7097f94df0c6667be2343306ffcda152fa22abcf/ghc
>---------------------------------------------------------------
commit 7097f94df0c6667be2343306ffcda152fa22abcf
Author: Gabor Greif <ggreif at gmail.com>
Date: Wed Jun 28 20:04:53 2017 +0200
Remove unneeded import
This fails in stage 2 when bootstrapping HEAD with HEAD
due to -Werror.
Turns out that tcInstBinders is now dead, and I'll remove it if nobody
protests. I'd like to hear opinions whether
tcInstBindersX then should be renamed to tcInstBinders.
>---------------------------------------------------------------
7097f94df0c6667be2343306ffcda152fa22abcf
compiler/typecheck/TcHsType.hs | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/compiler/typecheck/TcHsType.hs b/compiler/typecheck/TcHsType.hs
index 1b4deec..01cac59 100644
--- a/compiler/typecheck/TcHsType.hs
+++ b/compiler/typecheck/TcHsType.hs
@@ -56,7 +56,7 @@ import TcIface
import TcSimplify ( solveEqualities )
import TcType
import TcHsSyn( zonkSigType )
-import Inst ( tcInstBinders, tcInstBindersX, tcInstBinderX )
+import Inst ( tcInstBindersX, tcInstBinderX )
import Type
import Kind
import RdrName( lookupLocalRdrOcc )
@@ -422,7 +422,7 @@ metavariable.
In types, however, we're not so lucky, because *we cannot re-generalize*!
There is no lambda. So, we must be careful only to instantiate at the last
possible moment, when we're sure we're never going to want the lost polymorphism
-again. This is done in calls to tcInstBinders and tcInstBindersX.
+again. This is done in calls to tcInstBindersX.
To implement this behavior, we use bidirectional type checking, where we
explicitly think about whether we know the kind of the type we're checking
More information about the ghc-commits
mailing list