[commit: ghc] wip/rae: Clarify 13963 (fbb9aa7)
git at git.haskell.org
git at git.haskell.org
Tue Aug 22 18:39:31 UTC 2017
Repository : ssh://git@git.haskell.org/ghc
On branch : wip/rae
Link : http://ghc.haskell.org/trac/ghc/changeset/fbb9aa7a5d08a6b65c5294247c7c69a8014cfaf8/ghc
>---------------------------------------------------------------
commit fbb9aa7a5d08a6b65c5294247c7c69a8014cfaf8
Author: Richard Eisenberg <rae at cs.brynmawr.edu>
Date: Fri Aug 18 15:56:55 2017 -0400
Clarify 13963
>---------------------------------------------------------------
fbb9aa7a5d08a6b65c5294247c7c69a8014cfaf8
compiler/typecheck/TcHsType.hs | 2 ++
1 file changed, 2 insertions(+)
diff --git a/compiler/typecheck/TcHsType.hs b/compiler/typecheck/TcHsType.hs
index 162c904..fd8592a 100644
--- a/compiler/typecheck/TcHsType.hs
+++ b/compiler/typecheck/TcHsType.hs
@@ -1791,6 +1791,8 @@ tcTyClTyVars tycon_name thing_inside
-- type Syn k = forall (a :: k). Proxy a
-- At first, it looks like k should be named -- after all, it appears on the RHS.
-- However, the correct kind for Syn is (* -> *).
+ -- (Why? Because k is the kind of a type, so k's kind is *. And the RHS also has
+ -- kind *.) See also #13963.
correct_binders :: [TyConBinder] -> Kind -> [TyConBinder]
correct_binders binders kind
= binders'
More information about the ghc-commits
mailing list