[commit: ghc] wip/orf-reboot's head updated: Comment (3a53745)
git at git.haskell.org
git at git.haskell.org
Mon Oct 12 06:37:54 UTC 2015
Repository : ssh://git@git.haskell.org/ghc
Branch 'wip/orf-reboot' now includes:
09d0505 RetainerProfile: Add missing UNTAG_STATIC_LIST_PTR
b04bed0 renamer: fix module-level deprecation message
070f76a -include-pkg-deps takes only one hyphen.
7e70c06 Use isTrue# around primitive comparisons in integer-gmp
c55f61c Add missing parentheses in eqBigNatWord#
474d4cc Comment tweaks only
f842ad6 Implementation of StrictData language extension
2178273 Add UInfixT to TH types (fixes #10522)
81fffc4 Remove runSTRep from PrelNames
bc4b64c Do not inline or apply rules on LHS of rules
2d88a53 Improve warnings for rules that might not fire
09925c3 Revert "RetainerProfile: Add missing UNTAG_STATIC_LIST_PTR"
a1e8620 Revert "Eliminate zero_static_objects_list()"
e343c0a Test case for #10698
a1dd7dd Fallout from more assiduous RULE warnings
860e549 First stage of storing usage imports as GREs
4a01d40 Radically simplify ChildName and IE-related things
f83aab9 Eliminate zero_static_objects_list()
73d88ab Tidying up
2dbb01a Add a missing check for -fcpr-off
d1e7a92 Use NameEnv instead of list for storing used GREs; not clear if this helps performance
9aeac12 Fix handling of IEs
fac11f8 Comments only
4e8d74d Deal with phantom type variables in rules
92d2567 Define DsUtils.mkCastDs and use it
fa915af Spit out a little more info with -dppr-debug
e4114c8 Fix an outright error in competesWith
499b926 Fix Trac #10694: CPR analysis
918dcf8 The parallel package has warnings
2e33b9c Modify spec002 to be less trivial
72d23c3 Better treatment of signatures in cls/inst
24afe6d Fix missing files
5a8a8a6 Don't allowInterrupt inside uninterruptibleMask
9f7cdfe Make configure error out on missing ghc-tarballs on Windows
e7c331a Make headers C++ compatible (fixes #10700)
26315ed Fix misspelled function name in a comment
4f80ec0 Improve error message for newtypes and deriving clauses
e9ad42d Typos in comments and strings
d7c2b01 Fix comment that confused Haddock
b5097fe Testsuite: rename rename/should_fail/T5001 to T5001b (#5001)
e273c67 Testsuite: mark tests recently fixed as passing + accept new stderr
756fa0a Testsuite: skip T10489 unless compiler_debugged (#10489)
6880277 Testsuite: add arrows/should_compile/T5333 (#5333)
58b5f04 Testsuite: add typecheck/should_fail/T9260 (#9260)
58986c4 Testsuite: add typecheck/should_fail/T8034 (#8034)
aee19d0 Testsuite: T10245 is passing for WAY=ghci (#10245)
36bbfbd Backpack docs on renamer and depsolver, also s/package/unit/.
a442800 Build system: remove function keyword from configure.ac (#10705)
a66e1ba User's guide: delete ancient "Core syntax" example
7cf87df Fix #7919 (again)
353db30 Remove checked-in PDFs.
8f81af9 Typos in comments
ad089f5 Give raise# a return type of open kind (#10481)
75504f3 Typos in comments
15dd700 Replace (SourceText,FastString) with StringLiteral data type
d9b618f Typo in comment
37227d3 Make BranchFlag a new kind
92f5385 Support MO_U_QuotRem2 in LLVM backend
948e03e Update parallel submodule, and re-enable warnings
b38ee89 Fix incorrect stack pointer usage in StgRun() on x86_64
4d8859c Typos in comments
d7ced09 Minor improvement to user guide
30b32f4 Test Trac #10134
697079f 4 reduce/reduce parser conflicts resolved
d9d2102 Support wild cards in data/type family instances
7ec6ffc Typos in comments [skip ci]
64b6733 CmmParse: Don't force alignment in memcpy-ish operations
30c981e Removed deprecated syntax for GADT constuctors.
f063bd5 Fix #10713.
b5f1c85 Test #9233 in perf/compiler/T9233
d7b053a Pretty: reformat using style from libraries/pretty (#10735)
9d24b06 Pretty: rename variables to the ones used by libraries/pretty (#10735)
25bc406 Pretty: improve error messages (#10735)
53484d3 Pretty: remove superfluous parenthesis (#10735)
2d1eae2 Pretty: kill code that has been dead since 1997 (#10735)
6f6d082 Pretty: Args of NilAbove/TextBeside/Nest/Union are always RDocs (#10735)
926e428 Pretty: use BangPatterns instead of manual unboxing Ints (#10735)
f951ffc Pretty: mimic pretty API more closely (#10735)
85179b5 Pretty: use replicate for spaces and multi_ch (#10735)
dd7e188 Add framework flags when linking a dynamic library
4c55f14 users_guide: Add note about #367 to Bugs section
6029748 Drop custom mapM impl for []
ecb1752 Make -fcpr-off a dynamic flag
b12dba7 Make Exception datatypes into newtypes
22bbc1c Make sure that `all`, `any`, `and`, and `or` fuse (#9848)
fd6b24f Additions to users' guide and release notes
575abf4 Add Fixity info for infix types
e2b5738 Allow proper errors/warnings in core2core passes
617f696 Do not complain about SPECIALISE for INLINE
a426154 Warn about missed specialisations for imports
49615d9 Comments only
ab98860 Minor refactor to use filterInScope
9536481 Tidy up and refactor wildcard handling
28096b2 Fix quantification for inference with sigs
75f5f23 Coments only
cc07c40 Comments only
294553e T8968-1 and -3 should pass
64dba51 Test Trac #10742
eca9a1a Ensure DynFlags are consistent
97843d0 base: Add instances
600b153 llvmGen: Rework LLVM mangler
aa23054 Add test for #10600 (exhaustiveness check with --make and -fno-code)
bc43d23 Rejigger OSMem.my_mmap to allow building on Mac
a1c934c base: Add missing Traversable instance for ZipList
6cab3af Big batch of Backpack documentation edits.
79e0a10 Test Trac #10753
a192d6b Comments only
f1b4864 Sync base/changelog.md with GHC 7.10.2 release
590aa0f Make oneShot open-kinded
92f35cd cmmCreateSwitchPlan: Handle singletons up-front
2c4a7d3 Update transformers submodule to 0.4.3.0 release
f04c7be Fix unused-matches warnings in CmmLex.x
a40ec75 Update testsuite/.gitignore [skip ci]
b4ed130 Replace HsBang type with HsSrcBang and HsImplBang
2da06d7 User manual update, as prodded by #10760.
2b4710b Add missing </para> to User's guide to fix the build
8cce7e4 Bump template-haskell to new major version 2.11
67576dd Pretty: bugfix fillNB (#10735)
bcfae08 Pretty: fix potential bad formatting of error message (#10735)
5d57087 Pretty: fix a broken invariant (#10735)
85bf76a Pretty: show rational as is (#10735)
f903949 Pretty: improving the space/time performance of vcat, hsep, hcat (#10735)
b0dee61 template-haskell: Add changelog entry to infix type operators
7b211b4 Upgrade GCC to 5.2.0 for Windows x86 and x86_64
e415369 Update mingw tarball location
8c5b087 SysTools: Fix whitespace in error message
d2dd5af DynFlags: Prohibit hpc and byte-code interpreter
ec68618 Name: Show NameSort in warning
1857191 Testsuite: mark T8089 expect_broken(#7325) on Windows
8906037 Testsuite: mark encoding005 expect_broken(#10623) on Windows
ca85442 Testsuite: recenter 2 performance tests on Windows
744ff88 Testsuite: speedup running a single test
e367e27 Travis: prevent 10' no output, by setting VERBOSE=2
74897de Make rts/ThreadLabels.c threadsafe for debug runtime.
22aca53 Transliterate unknown characters at output
ab9403d Dump files always use UTF8 encoding #10762
b17ec56 Fix rdynamic flag and test on Windows
ebca3f8 rts/Printer.c: speed up '-Da' printer for 'LIBBFD' build
18a1567 Add selectors for common fields (DataCon/PatSyn) to ConLike
d97e60f Comments reformating/corrections
b6be81b Build system: delete half-baked Cygwin support
98f8c9e Delete sync-all
a146b28 GhcMake: Fix spelling in comment
0d0e651 Bag: Add Foldable instance
9e8562a Implement getSizeofMutableByteArrayOp primop
3452473 Delete FastBool
2f29ebb Refactor: delete most of the module FastTypes
47493e6 Build system: simplify install.mk.in
a1c008b Build system: delete unused distrib/Makefile
a5061a9 Check options before warning about source imports.
37a0b50 Delete ExtsCompat46 (#8330)
b78494e fix 64bit two-stage allocator on Solaris/AMD64 platform (#10790)
fba724c configure.ac: Allow disabling of large-address-space
1c643ba Fix algorithm.tex build and update with some new info.
0f3335f Comments and white space
816d48a Implement lookupGlobal in TcEnv, and use it
711e0bf tcRnDeclsi can use tcRnSrcDecls
ac0d052 TcDeriv: Kill dead code
de476e9 PrelNames: Clean up list a bit
89d25b9 BinIface: Clean up whitespace
7924469 Clean up handling of knownKeyNames
a8601a8 Revert "Clean up handling of knownKeyNames"
28ad98e PrelNames: introduce dcQual in place of conName
211b349 Move newImplicitBinder to from IfaceEnv to BuildTyCl
70ea94c IfaceEnv: Clean up updNameCache a bit
f6035bc MkIface: Introduce PatSynId, ReflectionId, DefMethId
7bd8f8f TysWiredIn: Shuffle code around
15c63d2 base: Remove a redundant 'return'
38c98e4 RTS: Reduce MBLOCK_SPACE_SIZE on AArch64
15cb83d Add testcase for #7411
a6826c5 Make Generic (Proxy t) instance poly-kinded (fixes #10775)
1b56c40 Respect GHC_CHARENC environment variable #10762
81ae26d Dwarf: Fix DW_AT_use_UTF8 attribute
cbf58a2 Dwarf: Produce {low,high}_pc attributes for compilation units
8476ce2 Dwarf: Produce .dwarf_aranges section
0c823af Fix identifier parsing in hp2ps
cd2dc9e ghc-pkg --enable-multi-instance should not complain about case sensitivity.
c7f0626 integer-gmp: optimise bitBigNat
c1d7b4b StgCmmHeap: Re-add check for large static allocations
60120d2 Fix 7.10 validate
12098c2 Fix typo in pattern synonym documentation.
10a0775 Anchor type family instances deterministically
ad26c54 Testsuite: refactoring only
6740d70 Use IP based CallStack in error and undefined
010e187 Fix trac #10413
ff9432f Add test for updating a record with existentially quantified fields.
296bc70 Use a response file for linker command line arguments #10777
ba5554e Allow annotations though addTopDecls (#10486)
c8f623e Expand declaration QQs first (#10047)
28ac9d3 Improve the error messages for class instance errors
3cc8f07 stm: Fix test case
5d7a873 Testsuite: don't warn about missing specialisations
e0b3ff0 Testsuite: update expected output
3b23379 Testsuite: mark 4 tests expect_broken_for(#10712, opt_ways)
32a9ead Fix some tests that were broken by D861
c43c8e2 Testsuite: by default run all tests for a single way
bd16e0b Testsuite: delete dead code
6b31bfe Horrible hacking to refactor HsRecField
3744578 Injective type families
5dc88b7 Add test for T10836 (expected broken)
34b106f Accept underscores in the module parser. (Thanks spinda for the fix.)
b639c97 Testsuite: fix tcfail220 - Maybe is wired-in now
e1293bb Testsuite: only print msg when timeout kills process unexpectedly
79cdb25 Testsuite: ignore line number differences in call stacks (#10834)
85915e9 Make Data.List.foldr1 inline
19c6049 Fix T6018th test failure
64761ce Build system: implement `make install-strip` (#1851)
5c372fe ghc-pkg: don't print ignored errors when verbosity=0
c60c462 user-guide: Add missing <para> tags around <listitem> body
96b986b EventLog: Factor out ensureRoomFor*Event
062feee tracing: Kill EVENT_STARTUP
2c24fd7 Build system: put each BuildFlavour in a separate file (#10223)
b40e559 Build system: simplify *-llvm BuildFlavours (#10223)
1abbacd Build system: cleanup utils/ghc-pkg/ghc.mk
dc671a1 SPECIALIZE strictMinimum for Int and Integer
c6b82e9 Further simplify the story around minimum/maximum
554be5e Build system: detect when user cloned from GitHub
864a9c4 Build system: remove hack for Mac OSX in configure.ac (#10476)
a158607 Build system: delete the InstallExtraPackages variable
330fbbd Build system: make *-cross BuildFlavours consistent (#10223)
8be43dd Build system: cleanup BUILD_DIRS + add lots of Notes
e4a73f4 Move GeneralCategory et al to GHC.Unicode
1b8eca1 Build system: check for inconsistent settings (#10157)
dbb4e41 HeapStackCheck: Small refactoring
4356dac Forbid annotations when Safe Haskell safe mode is enabled.
23a301a Testsuite: comment out `setnumcapabilities001` (#10860)
cdca31e Don't check in autogenerated hs files for recomp013.
3a71d78 Comments on oneShot
a870738 Improve rejigConRes (again)
487c90e Add a test for Trac #10806
a7f6909 A CFunEqCan can be Derived
377395e Improve documentation for transform list-comps
50d1c72 Fix broken links in documentation
413fa95 Improve documentation of comprehensions
f30a492 Testsuite cleanup
8c0eca3 Add assertions
18759cc Remove redundant language extensions
195af2d Dead code removal, export cleanup
4275028 Code movement
7ad4b3c s/StgArrWords/StgArrBytes/
89324b8 Testsuite: normalise slashes in callstack output
37081ac Testsuite: mark enum01-enum03 expect_broken(#9399) on Windows
3ec205a CodeGen: fix typo in error message
08af42f hpc: use `takeDirectory` instead of `dropWhileEnd (/= '/')`
c8d438f Testsuite: mark T6037 expect_fail on Windows (#6037)
12b0bb6 Account for stack allocation in the thread's allocation counter
14c4090 Pretty: fix unicode arrow operators.
325efac Fix `hp2ps -i-`
e66daec DynFlags: remove unused sPgm_sysman (#8689)
8d89d80 Testsuite: add test for #10781
43eb1dc Show minimal complete definitions in ghci (#10847)
8ecf6d8 ApplicativeDo transformation
77662e1 Add namePackage function to template-haskell
48746ff Docs: make sure all libs are included in index.html (#10879)
a8406f8 Pass TEST_HC_OPTS in bug1465 and T5792.
2d4db40 Fix #10815 by kind-checking type patterns against known kinds.
8ee2b95 Polish some error messages.
b89c491 Always run explicitly requested ways (extra_ways) for fast runs.
c738b12 Replace [PostTc id Type] with PostTc id [Type]
e156361 Put stable pointer names in the name cache.
1637e4d Driver: --make -o without Main should be an error (#10895)
1a13551 Test #10347
d19a77a Update user guide, fixing #10772
d7f2ab0 Test #10770
79b8e89 Print associated types a bit better.
1292c17 Allow TH quoting of assoc type defaults.
27f9186 Clarify parsing infelicity.
93fafe0 Re-polish error messages around injective TFs.
6a20920 Small improvement in pretty-printing constructors.
cbcad85 Fix typo in test for #10347.
2f9809e Slightly better `Coercible` errors.
e27b267 Perform a validity check on assoc type defaults.
8e8b9ed Run simplifier only when the env is clean.
cd2840a Refactor BranchLists.
c234acb `_ <- mapM` --> `mapM_`
3f13c20 Revert "Revert "Revert "Support for multiple signature files in scope."""
09d214d Revert "Revert "Revert "Change loadSrcInterface to return a list of ModIface"""
06d46b1 Unify hsig and hs-boot; add preliminary "hs-boot" merging.
d516d2e Fix build failure, I think.
07f6418 Remove graphFromVerticesAndAdjacency
5a8b055 TcDeriv: Use a NameEnv instead of association list
83e23c1 Remove (now bogus) assert.
0b852fc base: use Show for ErrorCall in uncaughtExceptionHandler
d4d34a7 Make derived names deterministic
089b72f DeriveLift extension (#1830)
4cdab73 HscMain: Place CPP macro invocation on one line
79f5732 testsuite: attempt fixing fallout from 089b72f52
c6bdf4f Remove references to () from types of mkWeak# and friends
65bf7ba DsBinds: Avoid using String when desugaring CallStack construction
939a7d6 Annotate CmmBranch with an optional likely target
cf90a1e Add constant-folding rule for Data.Bits.bit
73921df Update Cabal to recognize DeriveLift
453cdbf base: export allocation counter/limit API from System.Mem
5c11523 reify associated types when reifying typeclasses
39a262e Revert "reify associated types when reifying typeclasses"
2440e3c Fix a bug with mallocForeignPtr and finalizers (#10904)
b08a533d Fix DeriveGeneric for types with same OccName (#10487)
4f9ee91 Testsuite: update expected output for T8832 on 32-bit systems (#8832)
5883b56 Testsuite: properly fix T8832.stdout-ws-32 (#8832)
1395185 Testsuite: add test for #10767
fb40926 Weak: Don't require wrapping/unwrapping of finalizers
a98815a Dwarf: Rename binding to avoid shadowing ppr
a0b1f41 Dwarf: Ensure block length is encoded correctly
f7fd864 Skip a possible BOM in utf8 encoding
3fbf8f4 Debug: Remove extraneous LANGUAGE CPP
988b2ba rts: Clean up whitespace in Trace.h
b4d43b4 reify associated types when reifying typeclasses(#10891)
78053f4 Allow enumDeltaIntegerFB to be inlined
2eddcd9 Lexer: delete dead code for binary character literals
23baa65 .gitignore update for some test files.
e3ab25a Typos in comments
03b3804 Add Data.Semigroup and Data.List.NonEmpty (re #10365)
f2a174a Update nofib submodule
a52db23 Update nofib submodule again
baadd78 Merge remote-tracking branch 'origin/master' into wip/orf-reboot
ef07c2c Further refactoring of HsRecUpdField
cc7e5e9 Test wibbles
cd4fe28 Clarify a corner case with an additional test
c936cfb Remove unused ieNames
a3373da Remove confused debugging code
0071c36 Revert "Use NameEnv instead of list for storing used GREs; not clear if this helps performance"
9f84652 Revert "Tidying up"
9531e9e Revert "First stage of storing usage imports as GREs"
7b3b949 Refactoring RnNames
65f006c Further refactoring RnNames
794ce74 Better plusParent
dec2c1f Tidy up disambiguateRecordFields
f23c72e Comments only
be204f0 Resurrect a failing report-unused-imports test
6de6654 Store FieldOccs in tcg_used_selectors so we get import usage right
c72cd58 Clean up extendImportMap
f7d5e5c Comments only
46d2fc2 Don't addUsedRdrName for many ambiguous selectors at once
50c1b05 Get rid of isOverloadedRecFldGRE
d664c07 Qualified import to fix build pre-BBP
dc084f7 Add a test that deprecation warnings cannot be attached to DRFs
22349a7 Add test for deprecation warnings on non-duplicate fields
2c1386d Fix how addUsedRdrName is used to get correct deprecation warnings
3a53745 Comment
More information about the ghc-commits
mailing list