[commit: ghc] master: Improve HsBang (9564bb8)
git at git.haskell.org
git at git.haskell.org
Thu Jan 8 15:56:26 UTC 2015
Repository : ssh://git@git.haskell.org/ghc
On branch : master
Link : http://ghc.haskell.org/trac/ghc/changeset/9564bb8c84cbc0397a414e946cc8c28801f0fbe7/ghc
>---------------------------------------------------------------
commit 9564bb8c84cbc0397a414e946cc8c28801f0fbe7
Author: Simon Peyton Jones <simonpj at microsoft.com>
Date: Thu Jan 8 15:54:39 2015 +0000
Improve HsBang
Provoked by questions from Johan
- Improve comments, fix misleading stuff
- Add commented synonyms for HsSrcBang, HsImplBang, and use them throughout
- Rename HsUserBang to HsSrcBang
- Rename dataConStrictMarks to dataConSrcBangs
dataConRepBangs to dataConImplBangs
This renaming affects Haddock in a trivial way, hence submodule update
>---------------------------------------------------------------
9564bb8c84cbc0397a414e946cc8c28801f0fbe7
compiler/basicTypes/DataCon.hs | 105 ++++++++++++++++---------
compiler/basicTypes/MkId.hs | 30 +++----
compiler/deSugar/DsMeta.hs | 6 +-
compiler/hsSyn/Convert.hs | 4 +-
compiler/hsSyn/HsTypes.hs | 10 +--
compiler/iface/BuildTyCl.hs | 2 +-
compiler/iface/MkIface.hs | 6 +-
compiler/main/GHC.hs | 2 +-
compiler/parser/Parser.y | 10 +--
compiler/typecheck/TcExpr.hs | 2 +-
compiler/typecheck/TcRnDriver.hs | 2 +-
compiler/typecheck/TcSplice.hs | 16 ++--
compiler/typecheck/TcTyClsDecls.hs | 10 +--
compiler/vectorise/Vectorise/Type/TyConDecl.hs | 2 +-
utils/haddock | 2 +-
15 files changed, 119 insertions(+), 90 deletions(-)
Diff suppressed because of size. To see it, use:
git diff-tree --root --patch-with-stat --no-color --find-copies-harder --ignore-space-at-eol --cc 9564bb8c84cbc0397a414e946cc8c28801f0fbe7
More information about the ghc-commits
mailing list