[commit: ghc] master: Rename _closure to _static_closure, apply naming consistently. (3567207)
git at git.haskell.org
git at git.haskell.org
Thu Oct 2 06:11:02 UTC 2014
Repository : ssh://git@git.haskell.org/ghc
On branch : master
Link : http://ghc.haskell.org/trac/ghc/changeset/35672072b4091d6f0031417bc160c568f22d0469/ghc
>---------------------------------------------------------------
commit 35672072b4091d6f0031417bc160c568f22d0469
Author: Edward Z. Yang <ezyang at mit.edu>
Date: Mon Aug 26 15:23:15 2013 -0700
Rename _closure to _static_closure, apply naming consistently.
Summary:
In preparation for indirecting all references to closures,
we rename _closure to _static_closure to ensure any old code
will get an undefined symbol error. In order to reference
a closure foobar_closure (which is now undefined), you should instead
use STATIC_CLOSURE(foobar). For convenience, a number of these
old identifiers are macro'd.
Across C-- and C (Windows and otherwise), there were differing
conventions on whether or not foobar_closure or &foobar_closure
was the address of the closure. Now, all foobar_closure references
are addresses, and no & is necessary.
CHARLIKE/INTLIKE were not changed, simply alpha-renamed.
Part of remove HEAP_ALLOCED patch set (#8199)
Depends on D265
Signed-off-by: Edward Z. Yang <ezyang at mit.edu>
Test Plan: validate
Reviewers: simonmar, austin
Subscribers: simonmar, ezyang, carter, thomie
Differential Revision: https://phabricator.haskell.org/D267
GHC Trac Issues: #8199
>---------------------------------------------------------------
35672072b4091d6f0031417bc160c568f22d0469
compiler/cmm/CLabel.hs | 4 +-
compiler/deSugar/DsForeign.lhs | 6 +-
compiler/ghci/ByteCodeLink.lhs | 4 +-
compiler/main/DriverPipeline.hs | 4 +-
driver/utils/dynwrapper.c | 2 +-
ghc/GhciMonad.hs | 6 +-
includes/Cmm.h | 1 +
includes/Rts.h | 1 +
includes/RtsAPI.h | 12 ++--
includes/rts/StaticClosures.h | 34 +++++++++++
includes/rts/storage/ClosureMacros.h | 5 +-
includes/rts/storage/TSO.h | 2 +-
includes/stg/MiscClosures.h | 30 +++++-----
libraries/integer-gmp/cbits/gmp-wrappers.cmm | 4 +-
rts/Exception.cmm | 6 +-
rts/Interpreter.c | 2 +-
rts/Linker.c | 4 +-
rts/Prelude.h | 86 +++++++++++++++-------------
rts/PrimOps.cmm | 8 +--
rts/RaiseAsync.c | 4 +-
rts/RetainerProfile.c | 2 +-
rts/STM.c | 4 +-
rts/STM.h | 8 +--
rts/StgMiscClosures.cmm | 4 +-
rts/Weak.c | 6 +-
rts/package.conf.in | 72 +++++++++++------------
rts/posix/Signals.c | 4 +-
rts/sm/Storage.c | 4 +-
rts/win32/libHSbase.def | 34 +++++------
testsuite/tests/rts/rdynamic.hs | 2 +-
30 files changed, 203 insertions(+), 162 deletions(-)
Diff suppressed because of size. To see it, use:
git diff-tree --root --patch-with-stat --no-color --find-copies-harder --ignore-space-at-eol --cc 35672072b4091d6f0031417bc160c568f22d0469
More information about the ghc-commits
mailing list