[commit: ghc] wip/better-ho-cardinality's head updated: Improve the handling of used-once stuff (fe6512d)
git at git.haskell.org
git at git.haskell.org
Wed Dec 11 18:52:23 UTC 2013
Repository : ssh://git@git.haskell.org/ghc
Branch 'wip/better-ho-cardinality' now includes:
803afa3 In toHsType, filter out kind variables
5f3aa06 Typos in comments in TcEvidence
df37261 Typos in comments
6279a01 ghc.mk: one module name per line
9fbb8c7 Rejigger flushExec implementation (#8562, #8561)
a247887 Comment only
1812f44 Comment only
3ac1539 Add role-checking ASSERT to mkCast
f432229 Remove unused liftTcCoSubstWith
9d643cf Roleify TcCoercion
aef9044 Beginnings of removing EvCoercible
808ded9 Get rid of EvCoercible
9bc5b53 Coercible for impredicative types
3fcde74 Comments only
1df2116 EvCast needs to take a representational coercion
4d1ea48 Implement shortcuts for slow calls (#6084)
e9b0d36 Fix up shortcut for slow calls
9021737 Comments on slow-call-shortcutting
77e33bc -ddump-cmm: don't dump the proc point stage if we didn't do anything
6f7fa4e Refactor handleRunStatus some more, add comments and tidy up formatting
a8ac471 Fix the deugger (fixing Trac #8557)
f3a8416 More faff to get GHCi's top-level environment right
59e17d6 Fail (rather than addErr) if you use a bogus field in a pattern
9641641 Remove whitespace between macro identifiers and `(`
23efdd6 Update Notes for Coercible
ceb600d Minor fix to example GHC plugin in the documentation
2e3c6a5 Update "stolen syntax" section (#8575)
9c3c152 Call busy_wait_nop() in the spin-wait loop in shutdown_gc_threads()
de9f17e Update "stolen syntax" section (#8575)
4bbffb4 Fix documentation of FlexibleContexts (#8574)
adb9964 Fix loopification with profiling and enable it by default (#8275)
6d24076 Document solution to #8275
6178f6e Don't explicitly refer to nodeReg in ldvEnterClosure
ac31b79 Move the LDV code below the self-loop label (#8275)
574ccfa Respect the ordering of -package directives
fac831f Revert "Respect the ordering of -package directives"
5e86ea5 TcDeriv: s/isomorphism/coercible
bd7a125 With GND, report Coercible errors earliy
1791ea0 Print nicer error message for Coercible errors
06facab Refactor deferTcSForAllEq: Do not bind, but return EvTerm
249d47a Bind monadic stuff in getCoercibleInst locally, not via parameters
e1e9faf Handle Coercible (forall a. t) (forall a. t2) in TcInteract
b859c18 More links to [Coercible Instances]
3fecf81 Remove dead code orphaned by implementing GND with `coerce`.
4067340 Rejig rejigConRes & friends, doing role checks in a second pass.
b84fff3 Fix location of spliced-in role annotations.
90588c1 Move FunDeps to typecheck
cb17c1f Note [HyperStr and Use demands]
0fe399c Some popular typos in comments
51bebb7 Refactor: Origin of inferred Thetas
4025d66 Elaborate "deriving" error messages
586bc85 Mask async exceptions in forkM_
d14e5bf Export getHscEnv from HscMain
95ba5d8 More detailed error message when GND fails
356bc56 Fix note reference [WildCard binders]
e122154 Comments only
b67f503 Improve ASSERT
cd03893 Comments only
4f603db Untab ClosureTypes.h and ClosureFlags.c
9d7cbbc Remove code that generates FunDep error message context
55c703b Move the allocation of CAF blackholes into 'newCAF' (#8590)
fe68ad5 Update and deduplicate the comments on CAF management (#8590)
95854ca Use new flushExec implementation on all operating systems (#8562)
47024b6 Made ghc -e have a nonzero exit code upon failure (Trac #7962 )
415f0d6 Refactored by Simon Marlow's suggestion
d9ad369 Fix compiler warnings due to integer size mismatch
9d6f111 Comments, and rename a variable
8b642de Typecheck typed TH splices properly (fix Trac #8577)
0f2a20b Suggest TemplateHaskell after encountering a naked top-level expression
1c69305 Clean up Lexer.srcParseErr
1860dae Suggest TemplateHaskell after encountering a parse error on '$' (#7396)
8157a26 Add `.mailmap` file
980badd Remove the LFBlackHole constructor
8528165 Fix windows x86_64 build.
3f6da56 New flag: -ddump-strsigs
a31cb5b Do not forget CPR information after an IO action
f64cf13 Rename topDmdType to nopDmdType
3cdf125 Replace mkTopDmdType by mkClosedStrictSig
5e0fe05 Sort the output of -dump-strsigs
289ecda Add more .mailmap entries
7558231 Do not generate given kind-equalities (fix Trac #8566)
0849d02 Better debug printing
f114826 Spelling in comment
910b489 Some refactoring of Demand and DmdAnal
7583c20 Do not split void functions
c7b9505 Assign strictness signatures to primitive operations
5a92f04 Guarding against silly shifts
a9de79f Return exprArity, not manifestArity
fe6512d Improve the handling of used-once stuff
More information about the ghc-commits
mailing list