June 2007 Archives by author
Starting: Sun Jun 3 07:37:22 EST 2007
Ending: Fri Jun 29 13:28:14 EST 2007
Messages: 139
- [cvs-nhc98] patch applied (yhc): Change from using Play2 to using
Uniplate, fixing up all the names to the final versions
Neil Mitchell
- [cvs-nhc98] patch applied (yhc): Delete Play2, use Uniplate instead
Neil Mitchell
- [cvs-nhc98] patch applied (yhc): Remove the code to download and
demand Play
Neil Mitchell
- [cvs-nhc98] patch applied (yhc): Fix the sconscript in another
place to get the uniplate change going through (note to self
- always try actually compiling)
Neil Mitchell
- [cvs-nhc98] patch applied (yhc): Fix up various Uniplate stuff for
FreeVar2
Neil Mitchell
- [cvs-nhc98] patch applied (yhc): Fix up a few more uniplate/things
missing
Neil Mitchell
- [cvs-nhc98] patch applied (yhc): Removed an absolute dependency on
libgmp, however,
this should probably only be used on embedded platforms because:
Neil Mitchell
- [cvs-nhc98] patch applied (yhc): Move to using the filepath
supplied with GHC and released as 1.0
Neil Mitchell
- [cvs-nhc98] patch applied (yhc): Add a Cabal file for Yhc,
which can now build Yhc successfully
Neil Mitchell
- [cvs-nhc98] patch applied (yhc): Ignore the Setup.lhs when
compiling with Scons
Neil Mitchell
- [cvs-nhc98] patch applied (yhc): Fix up getDirectoryList to have
the same semantics as before (by stealing the code from the
filepath library)
Neil Mitchell
- [cvs-nhc98] patch applied (yhc): Only allow FilePath to export the
current System.FilePath (and version 11, since thats a dependency)
Neil Mitchell
- [cvs-nhc98] patch applied (yhc): Remove Binary and Filepath2 from
the dependencies, they aren't used
Neil Mitchell
- [cvs-nhc98] patch applied (yhc): Change some of the invariants
Neil Mitchell
- [cvs-nhc98] patch applied (yhc): More a little bit of code arrond,
and add a catch all clause from checkInvariant
Neil Mitchell
- [cvs-nhc98] patch applied (yhc): Add a uniqueNames module and policy
Neil Mitchell
- [cvs-nhc98] patch applied (yhc): Remove inaccurate comments
Neil Mitchell
- [cvs-nhc98] patch applied (yhc): A small library for Unique ID's in
Core
Neil Mitchell
- [cvs-nhc98] patch applied (yhc): Write FreeVar3,
a new attempt at a free variable library for Yhc.Core
Neil Mitchell
- [cvs-nhc98] patch applied (yhc): Move to using UniqueName to
generate the names for RecursiveLet
Neil Mitchell
- [cvs-nhc98] patch applied (yhc): Fix for removeRecursiveLet -
previously it did not look inside the bindings of
non-recursive let's to find a letrec,
so let a = letrec ... did not get processed (cycle is an example)
Neil Mitchell
- [cvs-nhc98] patch applied (yhc): Move RecursiveLet into the
Invariant namespae
Neil Mitchell
- [cvs-nhc98] patch applied (yhc): Reorder the functions in
UniqueName and add better haddock markers
Neil Mitchell
- [cvs-nhc98] patch applied (yhc): Add uniqueFuncsSplit,
to do most of the work of performing a computation that
"splits" functions into several elements
Neil Mitchell
- [cvs-nhc98] patch applied (yhc): Fix up removeRecursiveLet's to use
the new function splitting
Neil Mitchell
- [cvs-nhc98] patch applied (yhc): Add a lambda lifter to Yhc.Core
Neil Mitchell
- [cvs-nhc98] patch applied (yhc): Add an explicit export list for
UniqueName
Neil Mitchell
- [cvs-nhc98] patch applied (yhc): Add a function to rename functions
to have consecutive identifiers (makes it easier to read the
identifiers)
Neil Mitchell
- [cvs-nhc98] patch applied (yhc): Add lambda lifting to the list of
invariant stuff
Neil Mitchell
- [cvs-nhc98] patch applied (yhc): Move disjoint from Simplify to
Internal.General
Neil Mitchell
- [cvs-nhc98] patch applied (yhc): Make coreSimplify generalise to
anything with CoreExpr in therm
Neil Mitchell
- [cvs-nhc98] patch applied (yhc): Start work on the second
generation simplifier
Neil Mitchell
- [cvs-nhc98] patch applied (yhc): Added support for throwTo. Allows
throwing exceptions in other threads,
tries to conform as closely to the GHC semantics as possible.
Neil Mitchell
- [cvs-nhc98] patch applied (yhc): Added support for block/unblock on
exceptions
Neil Mitchell
- [cvs-nhc98] patch applied (yhc): Moved to switching based on
NEED_HEAPS rather than on single instructions
Neil Mitchell
- [cvs-nhc98] patch applied (yhc): Add and export duplicateVar from
FreeVar3
Neil Mitchell
- [cvs-nhc98] patch applied (yhc): Write the simplifier using the
unique variables precondition/postcondition
Neil Mitchell
- [cvs-nhc98] patch applied (yhc): Add and export
coreSimplifyExprUniqueExt - the extensible monadic simplifier
Neil Mitchell
- [cvs-nhc98] patch applied (yhc): Move changes to the invariant
library
Neil Mitchell
- [cvs-nhc98] patch applied (yhc): Add freeVars function to export
from FreeVar3
Neil Mitchell
- [cvs-nhc98] patch applied (yhc): Add lots more invariant stuff,
including case default removal
Neil Mitchell
- [cvs-nhc98] patch applied (yhc): Reorder the Yhc.Core export list,
and also export Invariant
Neil Mitchell
- [cvs-nhc98] patch applied (yhc): Add some more invariants (not
implemented yet)
Neil Mitchell
- [cvs-nhc98] patch applied (yhc): Yet more invariant stuff,
fixes up enough to get Supero going through
Neil Mitchell
- [cvs-nhc98] patch applied (yhc): Fix up haddock comments
Neil Mitchell
- [cvs-nhc98] patch applied (yhc): Turn off strip,
breaks with the latest version of cpphs (since the //
is now stripped)
Neil Mitchell
- [cvs-nhc98] patch applied (yhc): Move from C style comments to HS
style comments
Neil Mitchell
- [cvs-nhc98] patch applied (yhc): Move to CPP style comments (#if 0)
in Types.h, at the suggestion of isaacd
Neil Mitchell
- [cvs-nhc98] patch applied (york-compiler98): Change the Sconscript
to build the compiler
Neil Mitchell
- [cvs-nhc98] patch applied (york-compiler98): Port the recent change
to cpphs vs Yhc into the NYHC branch
Neil Mitchell
- [cvs-nhc98] patch applied (york-compiler98): Move PreImport to use
tYHCInternal (this may break nhc,
I don't know how this stuff works...)
Neil Mitchell
- [cvs-nhc98] patch applied (yhc): Added a NO_SHARED flag to
platform.h that should make shared libraries optional
Neil Mitchell
- [cvs-nhc98] patch applied (yhc): Update scons build yhc,
scons update and scons push to work with the new Yhc
compiler directory
Neil Mitchell
- [cvs-nhc98] patch applied (york-compiler98): Fix the comments so
they all go through with Haddock
Neil Mitchell
- [cvs-nhc98] patch applied (york-compiler98): Fix up imports so that
the Yhc side builds with the Flags changes
Neil Mitchell
- [cvs-nhc98] patch applied (yhc): Change so that flags passed to Yhc
follow the --convention
Neil Mitchell
- [cvs-nhc98] patch applied (yhc): Split out the gmp_configure bit,
and only do it if building Yhi
Neil Mitchell
- [cvs-nhc98] patch applied (yhc): Add a little bit more trickery to
try and get GMP detection working again
Neil Mitchell
- [cvs-nhc98] patch applied (yhc): Lots of changes to OPTIONS_YHC
pragma's to follow the new command line rules
Neil Mitchell
- [cvs-nhc98] patch applied (yhc): No longer necessary to give -unlit
to the literate files (auto-detected)
Neil Mitchell
- [cvs-nhc98] patch applied (york-compiler98): Fix up haddock
annotations in Flags.hs (was breaking haddock)
Neil Mitchell
- [cvs-nhc98] patch applied (yhc): Update the Haskell build system in
light of new changes
Neil Mitchell
- [cvs-nhc98] patch applied (yhc): Fix up the Haskell build system to
grab the Yhc compiler
Neil Mitchell
- [cvs-nhc98] patch applied (yhc): Make the Yhi builder do linking as
well
Neil Mitchell
- [cvs-nhc98] merging nhc98 and yhc
Sven Panne
- [cvs-nhc98] patch applied (cpphs): allow spaces surrounding ##
string catenator
Malcolm Wallace
- [cvs-nhc98] patch applied (cpphs): oops,
some expected test results should have been committed earlier
Malcolm Wallace
- [cvs-nhc98] patch applied (cpphs): include expected trailing
newlines
Malcolm Wallace
- [cvs-nhc98] patch applied (cpphs): another test (36b) for string
catenation
Malcolm Wallace
- [cvs-nhc98] patch applied (cpphs): Completely refactor the
options-processing code.
Malcolm Wallace
- [cvs-nhc98] patch applied (cpphs): minor refactoring for readability
Malcolm Wallace
- [cvs-nhc98] patch applied (cpphs): add defaultCpphsOptions and
defaultBoolOptions
Malcolm Wallace
- [cvs-nhc98] patch applied (cpphs): Expand macros during first
(conditional) phase of processing.
Malcolm Wallace
- [cvs-nhc98] patch applied (cpphs): export default*Options
Malcolm Wallace
- [cvs-nhc98] patch applied (cpphs): documentation fixes
Malcolm Wallace
- [cvs-nhc98] patch applied (cpphs): Avoid name clash between
L.P.C.Options.unlit and L.P.Unlit.unlit
Malcolm Wallace
- [cvs-nhc98] patch applied (cpphs): thinko in parsing macro calls
Malcolm Wallace
- [cvs-nhc98] patch applied (cpphs): another missing expected test
result
Malcolm Wallace
- [cvs-nhc98] patch applied (cpphs): Recursively expand textual
replacements in conditionals.
Malcolm Wallace
- [cvs-nhc98] patch applied (cpphs): whitespace fixes in expected
results
Malcolm Wallace
- [cvs-nhc98] patch applied (cpphs): test for expansion of
param.macros in #include
Malcolm Wallace
- [cvs-nhc98] patch applied (cpphs): call new test (expect15a)
Malcolm Wallace
- [cvs-nhc98] patch applied (cpphs): Move parsing of #include
filename into CppIfdef
Malcolm Wallace
- [cvs-nhc98] patch applied (cpphs): bump version number to 1.5
Malcolm Wallace
- [cvs-nhc98] patch applied (cpphs): TAG version 1.5
Malcolm Wallace
- [cvs-nhc98] patch applied (cpphs): need type signatures for haddock
Malcolm Wallace
- [cvs-nhc98] patch applied (cpphs): date of release
Malcolm Wallace
- [cvs-nhc98] patch applied (cpphs): TAG no, really version 1.5 now
Malcolm Wallace
- [cvs-nhc98] patch applied (cpphs): update Makefile.nhc98 with new
dependencies
Malcolm Wallace
- [cvs-nhc98] patch applied (cpphs): sigh,
dependencies for .hc files too
Malcolm Wallace
- [cvs-nhc98] patch applied (nhc98): track recent changes in cpphs
(which hmake depends on)
Malcolm Wallace
- [cvs-nhc98] patch applied (nhc98): Desugaring of comprehensions and
enumerations moves from parser to renamer.
Malcolm Wallace
- [cvs-nhc98] patch applied (nhc98): add type signatures (only)
Malcolm Wallace
- [cvs-nhc98] patch applied (nhc98): Parse and pretty-print pattern
guards.
Malcolm Wallace
- [cvs-nhc98] patch applied (nhc98): Thread pattern guards through
the rest of the compiler
Malcolm Wallace
- [cvs-nhc98] patch applied (nhc98): test for pattern guards
Malcolm Wallace
- [cvs-nhc98] patch applied (nhc98): Translate pattern guards to
PosLambda code.
Malcolm Wallace
- [cvs-nhc98] patch applied (hat): improve ghc-version detection at
install time
Malcolm Wallace
- [cvs-nhc98] patch applied (hat): reduce version in cabal file from
2.06 to 2.05 to match elsewhere
Malcolm Wallace
- [cvs-nhc98] patch applied (cpphs): test for stripping // eol
comments (C++-style)
Malcolm Wallace
- [cvs-nhc98] patch applied (cpphs): strip //-style eol comments in
--strip mode as well as /* these */
Malcolm Wallace
- [cvs-nhc98] patch applied (york-compiler98): remove cpp #ifdefs
Malcolm Wallace
- [cvs-nhc98] patch applied (york-compiler98): TAG fully merged
nhc98/yhc sources
Malcolm Wallace
- [cvs-nhc98] merging nhc98 and yhc
Malcolm Wallace
- [cvs-nhc98] patch applied (nhc98): link with the base package by
default
Malcolm Wallace
- [cvs-nhc98] patch applied (nhc98): remove the --strip option from
cpphs when preprocessing for nhc98
Malcolm Wallace
- [cvs-nhc98] patch applied (nhc98): link with the base package
by default
Malcolm Wallace
- [cvs-nhc98] patch applied (york-compiler98): Change the Sconscript
to build the compiler
Malcolm Wallace
- [cvs-nhc98] patch applied (york-compiler98): fix nhc98 Makefile
with new names for modules
Malcolm Wallace
- [cvs-nhc98] patch applied (york-compiler98): Clone some symbols for
useful imported entities.
Malcolm Wallace
- [cvs-nhc98] patch applied (york-compiler98): New solution to the
differences between nhc98 and yhc.
Malcolm Wallace
- [cvs-nhc98] patch applied (nhc98): convert C comments to Haskell
comments for cpphs
Malcolm Wallace
- [cvs-nhc98] patch applied (york-compiler98): Process cmdline flags
with GetOpt rather than home-grown buggy code.
Malcolm Wallace
- [cvs-nhc98] patch applied (york-compiler98): need multiple objdirs
in compiler98 now
Malcolm Wallace
- [cvs-nhc98] patch applied (york-compiler98): command-line
non-options are probably files to compile :-)
Malcolm Wallace
- [cvs-nhc98] patch applied (york-compiler98): nhc98 and yhc differ
in how they accept filenames on the command line
Malcolm Wallace
- [cvs-nhc98] patch applied (york-compiler98): More nhc98/yhc
differences: imports and pre-imports.
Malcolm Wallace
- [cvs-nhc98] patch applied (york-compiler98): note module Building
in Makefile
Malcolm Wallace
- [cvs-nhc98] patch applied (nhc98): Test for mixed ordinary guards
with pattern guards.
Malcolm Wallace
- [cvs-nhc98]
patch applied (york-compiler98): Remove ordinary guards,
keeping just pattern guards.
Malcolm Wallace
- [cvs-nhc98] patch applied (york-compiler98): Remove obsolete
commented-out Guard code.
Malcolm Wallace
- [cvs-nhc98] patch applied (york-compiler98): nhc98/yhc differences:
interface file format for instance decls
Malcolm Wallace
- [cvs-nhc98] patch applied (york-compiler98): fix typo
Malcolm Wallace
- [cvs-nhc98] patch applied (york-compiler98): Require tokenDynamic
only for yhc.
Malcolm Wallace
- [cvs-nhc98] patch applied (york-compiler98): nhc98/yhc difference:
code generation (STG stage)
Malcolm Wallace
- [cvs-nhc98] patch applied (york-compiler98): nhc98/yhc difference:
fiddle with Rational constructor
Malcolm Wallace
- [cvs-nhc98] patch applied (york-compiler98): where do err functions
like _patternMatchFail come from?
Malcolm Wallace
- [cvs-nhc98] patch applied (york-compiler98): wibble to printing
'Id's
Malcolm Wallace
- [cvs-nhc98] merging nhc98 and yhc
Malcolm Wallace
- [cvs-nhc98] patch applied (york-compiler98): nhc98/yhc difference:
instance method qualification
Malcolm Wallace
- [cvs-nhc98] patch applied (york-compiler98): allow --nkpat as well
as --nplusk
Malcolm Wallace
- [cvs-nhc98] patch applied (york-compiler98): nhc98/yhc difference:
primitives vs bytecodes
Malcolm Wallace
- [cvs-nhc98] patch applied (york-compiler98): 'make clean' wibble
Malcolm Wallace
- [cvs-nhc98] patch applied (york-compiler98): TAG working nhc98
after the merge
Malcolm Wallace
- [cvs-nhc98] patch applied (nhc98): Remove the compiler98 directory
completely
Malcolm Wallace
- [cvs-nhc98] patch applied (nhc98): graft in the merged nhc98/yhc
compiler98 repository
Malcolm Wallace
- [cvs-nhc98] patch applied (nhc98): configuration/flags update for
merged compiler
Malcolm Wallace
- [cvs-nhc98] patch applied (nhc98): add yhc-style error messages to
NHC.Internal
Malcolm Wallace
- [cvs-nhc98] patch applied (nhc98): fiddle with cmdline flags to
ensure new -- format
Malcolm Wallace
Last message date:
Fri Jun 29 13:28:14 EST 2007
Archived on: Fri Jun 29 13:22:23 EST 2007
This archive was generated by
Pipermail 0.09 (Mailman edition).