cvs commit: fptools/libraries/base/Control/Monad MonadRec.hs

Levent Erkok erkok@cse.ogi.edu
Mon, 30 Sep 2002 09:58:54 -0700


I agree with Simon. For compatibility, we should use "Control.Monad.Rec" for 
the library name and "MonadRec" for the class name. 

Having said that, I also agree with Ross and Jeff: There's a good argument
for naming the class MonadFix. That'll break a couple of things out there 
(including disagreement with a bunch of already published stuff), but if 
that's the right thing to do, we shouldn't hesitate.

So, given Ross and Jeff argue strongly, and since the user base is small enough, 
I think we should go ahead and use the names "MonadFix" and "Control.Monad.Fix".

-Levent.
_______________________________________________
Cvs-libraries mailing list
Cvs-libraries@haskell.org
http://www.haskell.org/mailman/listinfo/cvs-libraries