why is not possible to update cabal to 1.22 ? (Ubuntu 14.04)

Daniel Bergey bergey at teallabs.org
Wed Apr 27 14:35:09 UTC 2016

In general, you need a version of cabal that matches the version of

My guess is you have cabal-install-1.16 earlier on PATH than the
cabal-install that comes with Haskell Platform, and that removing it
will solve your problem.

If you answer these questions, that will help me give more specific advice:

How did you install Haskell Platform (Ubuntu 14.04 package?  PPA?

What is the output of the following commands:
which ghc
which cabal
ghc --version
cabal --version
echo $PATH


On 2016-04-27 at 08:08, Juan Carlos Saenz Carrasco <jcsaenzcarrasco at gmail.com> wrote:
> Hello
> I have tried to update, upgrade, and finally uninstall and reinstall again haskell
> platform in order to get the latest version for cabal since the current version 1.16
> (running under Ubuntu 14.04 ) always triggers the following error message not matter
> what package I try to install:
> ghc: ghc no longer supports single-file style package databases (dist/
> package.conf.inplace) use 'ghc-pkg init' to create the database with the correct format.
> Failed to install XXX
> ...
> ExitFailure 1
> I have also tried 
> cabal install cabal-install- --global --force-reinstalls
> but again, it fails.
> Thanks,
> JC
> _______________________________________________
> cabal-devel mailing list
> cabal-devel at haskell.org
> http://mail.haskell.org/cgi-bin/mailman/listinfo/cabal-devel

More information about the cabal-devel mailing list