Cabal can't open a TCP connection

Simon Peyton Jones simonpj at
Thu May 8 16:20:16 UTC 2014

Spot on, Kim-Ee.  Thanks.  unsetting http_proxy fixed it.

I’m fwding to cabal-devel: it would be great that if “http_proxy” was set to “”, then it behaved just as if it was un-set.  The current behaviour is very confusing (to me anyway).


From: Kim-Ee Yeoh [mailto:ky3 at]
Sent: 08 May 2014 14:48
To: Simon Peyton Jones
Cc: Herbert Valerio Riedel; Simon Marlow; ghc-devs at
Subject: Re: Cabal can't open a TCP connection

On Thu, May 8, 2014 at 8:22 PM, Simon Peyton Jones <simonpj at<mailto:simonpj at>> wrote:
On a machine that doesn't need to use a proxy server, what should $http_proxy be set to?

It's a Maybe (Maybe String) problem. Blame Cabal for not ignoring an empty http_proxy. The *nix programs I've tried treat empty as unset.
The solution is: unset HTTP_PROXY.

-- Kim-Ee

Från: Simon Peyton Jones<mailto:simonpj at>
Skickat: ‎2014-‎05-‎08 14:04
Till: ghc-devs at<mailto:ghc-devs at>
Kopia: Simon Marlow<mailto:marlowsd at>
Ämne: Cabal can't open a TCP connection
Dear ghc-devs
Cabal can’t open a TCP connection from my Linux box.  It used to work fine.  Here’s what it says:

cabal -v3 update

Downloading the latest package list from



User-Agent: cabal-install/


proxy uri host: , port:

Creating new connection to

cabal: openTCPConnection: host lookup failure for ""

simonpj at cam-05-unx:~/code/HEAD$ cabal --version

cabal-install version

using version of the Cabal library

simonpj at cam-05-unx:~/code/HEAD$
Can anyone help me work out what to do?  git works just fine, so the internet is connected all right.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the cabal-devel mailing list