cabal-install-1.18 on GHC-6.12

Herbert Valerio Riedel hvr at
Mon Oct 28 09:39:59 UTC 2013

On 2013-10-28 at 09:31:49 +0100, Johan Tibell wrote:


>> Johan, was it you who cherry-picked it from master? Wasn't 1.18
>> supposed to still support 6.12?

> This is my fault. I don't know if it's worth another Cabal release to fix
> it though. 6.12 is more than 3 years old now.

Fwiw, GHC 6.12.x was the last major GHC release *not* to support
'default-language: Haskell2010' out-of-the-box.

Btw, are there any Linux distribution release out there which have not
reached end-of-life and yet provide GHC 6.12.x as their default GHC? 

Or put differently, how many active GHC <=6.12.x users are there, which
haven't upgraded GHC but still want to upgrade Cabal & cabal-install?


More information about the cabal-devel mailing list