Agreeing on a UI for sandboxes

Mikhail Glushenkov the.dead.shall.rise at
Tue Sep 4 23:17:04 CEST 2012


On Tue, Sep 4, 2012 at 12:52 AM, Johan Tibell <johan.tibell at> wrote:
> On Mon, Sep 3, 2012 at 12:50 PM, Mikhail Glushenkov
> <the.dead.shall.rise at> wrote:
>> -It's just that I had a version using install already working. It'll
>> take me a bit more time to make it use configure/build/register
>> instead. I'm a bit busy right now, so this will have to wait until
>> next week.
> No problem. There's no rush.

I looked more closely into this, and it seems like the easiest
solution is a --no-download flag for "install". It can be implemented
either by exiting with error if the install plan contains packages
that aren't already installed (forcing the user to run "install
--only-dependencies") or by somehow coaxing the constraint solver into
rejecting such packages (is this possible?).

()  ascii ribbon campaign - against html e-mail
/\   - against proprietary attachments

More information about the cabal-devel mailing list