ANN: Cabal- and cabal-install-

Johan Tibell johan.tibell at
Wed Oct 24 18:42:48 CEST 2012


On behalf of the cabal contributors, I'm proud to announce bugfix
releases of Cabal and cabal-install. Here's a complete list of changes
since the last release:

Since Cabal-

* Bump Cabal version number to
* Fixed warnings on the generated Paths module. The warnings are
generated by the flag '-fwarn-missing-import-lists'.

Since cabal-install-1.16.0:

* Have use Cabal-
* Fix installing from custom folder on Linux (#1058)
* Change to require Cabal >= 1.16 && < 1.18
* Bump cabal-install version number to
* Bump network dependency in to
* Fix compilation error
* Disable setting the jobs: $nprocs line in default ~/.cabal config
* Fix building cabal-install with ghc-6.12 and older

I expect this to be the last release from the 1.16 branch. I intend to
make another in about 3 months, or a bit sooner if the sandboxing work
is ready earlier.


More information about the cabal-devel mailing list