Patch to let hackage-server build with GHC <= 7.4.1

Bas van Dijk v.dijk.bas at
Wed Jan 11 23:06:40 CET 2012

Hi Antoine,

On 11 January 2012 17:51, Antoine Latter <aslatter at> wrote:
> Was the 'instance FromReqURI Method' meant to be in this bundle?

Yes, it's needed because of the new happstack-server-6.4.

> This change requires hackage-server 6.4 - does that build with GHC
> 6.12 (and is it okay if it doesn't?)? I haven't had a chance to test
> that.

I just confirmed that happstack-server builds on ghc-6.12.3. (Note
that I first had to unregister the system base- because
otherwise I couldn't install syb >= 0.3.3 which is required by json).


More information about the cabal-devel mailing list