A-posteriori .cabal updates don't help (much) with optimistic-upper-bounds (was: Gearing up for a cabal-install-1.16.0 release)

Malcolm Wallace malcolm.wallace at me.com
Mon Dec 3 14:48:06 CET 2012

On 3 Dec 2012, at 11:35, Herbert Valerio Riedel wrote:

> 2) there's a package text-foo which depends on 'text >= 0.10' (i.e. with no
>   upper bound), for which N versions exist on Hackage (all with
>   the same 'text >= 0.10' constraint):
>   0.1.0,,, 0.1.1, 0.1.2, 0.2, ...some more... ,
> 4) text-foo-'s .cabal file is updated server-side to have the
>   version constraint set to 'text >= 0.10 && text < 0.11'
> Alas, 4) isn't enough, as it leaves N-1 versions of text-foo with an
> invalid version constraint

I don't understand why you suggest that only the most recently uploaded version of text-foo would have its cabal file updated on the server.  If the scheme is going to work at all, it must update _every_ version of text-foo that could be affected.

Is that an unrealistic expectation?


More information about the cabal-devel mailing list