[Hackage] #282: profiling versions of libraries not managed well

Chris Dornan chris at chrisdornan.com
Fri Sep 30 02:44:40 CEST 2011

Developer Peeps,

If I set up GHC_PACKAGE_PATH and use cabal-install to install a package it gives me:

	cabal: transformers- dependency
	"base-" doesn't exist (use --force to

for each library it tries to install.

Is there an easy way to get cabal to work with GHC_PACKGE_PATH smoothly? (Apologies in advance for the stupid question.)


-----Original Message-----
From: cabal-devel-bounces at haskell.org [mailto:cabal-devel-bounces at haskell.org] On Behalf Of Hackage
Sent: 29 September 2011 13:53
Cc: cabal-devel at haskell.org
Subject: Re: [Hackage] #282: profiling versions of libraries not managed well

#282: profiling versions of libraries not managed well
  Reporter:  SamB                |        Owner:           
      Type:  defect              |       Status:  new      
  Priority:  normal              |    Milestone:           
 Component:  cabal-install tool  |      Version:  
  Severity:  normal              |     Keywords:  profiling
Difficulty:  hard (< 1 day)      |   Ghcversion:  6.8.2    
  Platform:                      |  
Changes (by bgamari):

 * cc: bgamari@… (added)

Ticket URL: <http://hackage.haskell.org/trac/hackage/ticket/282#comment:9>
Hackage <http://haskell.org/cabal/>
Hackage: Cabal and related projects

cabal-devel mailing list
cabal-devel at haskell.org

More information about the cabal-devel mailing list