[Hackage] #896: cabal install cabal-install fails if gcc not in /Developer/usr/bin/gcc

Hackage cvs-ghc at haskell.org
Mon Oct 24 03:08:36 CEST 2011

#896: cabal install cabal-install fails if gcc not in /Developer/usr/bin/gcc
  Reporter:  jeremyw.sherman     |        Owner:         
      Type:  defect              |       Status:  new    
  Priority:  normal              |    Milestone:         
 Component:  cabal-install tool  |      Version:
  Severity:  normal              |     Keywords:         
Difficulty:  unknown             |   Ghcversion:         
  Platform:  Mac OS              |  

Comment(by jeremyw.sherman):

 I am sure that /Developer/usr/bin/gcc did not exist. I have different
 versions of Xcode installed in /Xcode_3_2_6 and /Xcode_4_2, but no version
 installed in /Developer. Just so it would build, I ran `sudo ln -s
 /Xcode_4_2 /Developer`, and it successfully built after that.

 My `PATH` does not include any /Developer or /Xcode* directory. I also do
 not have `CC` set in my shell environment variables.

 I tried using --with-gcc and --with-cc to give it the correct compiler,
 and it ignored me and tried to use the /Developer one. Based on your
 comment, the issue there looks to have been that I did not use an equals
 sign between the option and argument, that is, I wrote

   `--with-gcc /Xcode_4_2/usr/bin/clang`

 instead of


 All I can think is that it had to have been somehow hardcoded to look in
 /Developer, since that's the default install location for Xcode. Xcode
 also installs the build tools under /usr/bin, no matter what directory
 Xcode itself was installed to, so that path is more reliable.

Ticket URL: <http://hackage.haskell.org/trac/hackage/ticket/896#comment:2>
Hackage <http://haskell.org/cabal/>
Hackage: Cabal and related projects

More information about the cabal-devel mailing list