patch applied (cabal): "Fix the GHC HEAD build: Don't use deprecated catch function"

Ross Paterson ross at
Mon May 23 16:54:24 CEST 2011

On Wed, Apr 27, 2011 at 02:02:25PM +0100, Ian Lynagh wrote:
> On Wed, Apr 27, 2011 at 01:16:12PM +0100, Duncan Coutts wrote:
> > 
> > The generated paths module has to compile with the target
> > compiler, including older ghc
> Why? People who really are stuck with GHC 6.8 already have a Cabal that
> works with it. They're going to be stuck if they want to use anything
> that requires base 4, or if they want to build a recent GHC, etc,
> though.

The version of GHC on abbot is 6.8.2, so this can't be used by the
hackage scripts.

More information about the cabal-devel mailing list