[bug] Test suite peiling up?

Bram Neijt bneijt at gmail.com
Mon Jun 13 20:35:39 CEST 2011

Dear List,

I'm new to haskell and the first thing I want to get working is test,
to enable me to explore the language through righting tests.

I've tried to use cabal to run tests, but found very little
documentation. In the end, I found the test-suite feature of cabal >=
1.9.2, which I have set up as best I can in the attachment.

If I run :
cabal configure --enable-tests; cabal test

multiple times, I will get more and more output, as if it is adding
tests to a list even though the tests are already there.

To reproduce:
- Extract the attached archive of code
- Enter the source directoy
- Run cabal configure --enable-tests; cabal test
  multiple times

Expected result: Only one test is executed every time I run cabal test.
Actual result: it adds the same test to a list every time.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: bug-0.1.tar.gz
Type: application/x-gzip
Size: 457 bytes
Desc: not available
URL: <http://www.haskell.org/pipermail/cabal-devel/attachments/20110613/5a9d07dc/attachment.bin>

More information about the cabal-devel mailing list