[Hackage] #832: Cabal aggregates dependencies for executables

Hackage cvs-ghc at haskell.org
Mon Apr 18 13:40:40 CEST 2011

#832: Cabal aggregates dependencies for executables
  Reporter:  juhp           |        Owner:          
      Type:  defect         |       Status:  new     
  Priority:  normal         |    Milestone:          
 Component:  Cabal library  |      Version:
  Severity:  normal         |     Keywords:          
Difficulty:  unknown        |   Ghcversion:          
  Platform:                 |  

Comment(by duncan):

 If you change to `cabal-version: >= 1.8` then it should do what you

 This was an old bug but we could not immediately fix it since there were
 lots of old packages that accidentally relied on this bug. So the fixed
 behaviour is opt-in by requiring a sufficiently new cabal version.

 I'll leave this ticket open for a bit so you can check if this does indeed
 fix it for you. Also, if you have any suggestion on how to make this more
 discoverable, that'd also be welcome.

Ticket URL: <http://hackage.haskell.org/trac/hackage/ticket/832#comment:1>
Hackage <http://haskell.org/cabal/>
Hackage: Cabal and related projects

More information about the cabal-devel mailing list