[Hackage] #756: weird ghc dependency on array

Hackage cvs-ghc at haskell.org
Sun Oct 31 18:01:49 EDT 2010

#756: weird ghc dependency on array
  Reporter:  graphov             |        Owner:                          
      Type:  defect              |       Status:  new                     
  Priority:  normal              |    Milestone:                          
 Component:  cabal-install tool  |      Version:                 
  Severity:  normal              |     Keywords:  cabal-install dependency
Difficulty:  unknown             |   Ghcversion:  6.12.1                  
  Platform:  Linux               |  
 I've upgrade Cabal to current version using cabal-install and got this
 weird dependency error:

 druid at lambda-server:~$ cabal install on-a-horse
 Resolving dependencies...
 cabal: dependencies conflict: ghc-6.12.1 requires array == however
 array- was excluded because ghc-6.12.1 requires array ==

 Seems like ghc-6.12.1 depends on both arrays simultaneously.

 Ubuntu 10.10 amd64
 ghc 6.12.1, shipped with Ubuntu
 All other packages are built from hackage, not from Ubuntu packages

Ticket URL: <http://hackage.haskell.org/trac/hackage/ticket/756>
Hackage <http://haskell.org/cabal/>
Hackage: Cabal and related projects

More information about the cabal-devel mailing list