[Hackage] #93: Incorrect permissions on library install

Hackage cvs-ghc at haskell.org
Wed Nov 3 09:24:15 EDT 2010

#93: Incorrect permissions on library install
  Reporter:  guest          |        Owner:           
      Type:  defect         |       Status:  reopened 
  Priority:  normal         |    Milestone:  Cabal-1.8
 Component:  Cabal library  |      Version:  
  Severity:  normal         |   Resolution:           
  Keywords:                 |   Difficulty:  normal   
Ghcversion:  6.12.1         |     Platform:  Linux    
Changes (by guest):

  * ghcversion:  6.10.1 => 6.12.1
  * version:  1.1.4 =>


 It hasn't been mentioned that this actually causes a system-level problem
 GNU/Linux which potentially makes it more severe: it makes the mandb cron
 task at least complain and, I think, actually fail after getting
   /usr/bin/mandb: can't open /usr/local/share/man/man1/markdown2pdf.1:
 Permission denied
 following a `cabal install --global pandoc', although the binary is
 appropriately.  This is with
   cabal-install version 0.8.2
   using version of the Cabal library
 -- d.love(haskell) @ liv.ac.uk

Ticket URL: <http://hackage.haskell.org/trac/hackage/ticket/93#comment:10>
Hackage <http://haskell.org/cabal/>
Hackage: Cabal and related projects

More information about the cabal-devel mailing list