Problem with cabal-install 0.6 and data-accessor

Henning Thielemann lemming at
Tue Jun 1 14:10:34 EDT 2010

On Tue, 1 Jun 2010, Duncan Coutts wrote:

>>> The tested-with field reads:
>>>   Tested-With:      GHC==6.4.1 && ==6.8.2 && ==6.10.4, JHC==0.7.3
> Ohhh. I'd not realised that when we extended the version range parser
> that this would affect the "tested-with" field too. It's obvious in
> retrospect of course.
> So we need to add a QA check for that. At the same time we should check
> that the tested-with makes any sense. In particular we should check that
> the version constraints are not self-inconsistent.
> The value "GHC==6.4.1 && ==6.8.2 && ==6.10.4" is not consistent. You
> meant "GHC==6.4.1, GHC==6.8.2, GHC==6.10.4"

Sounds reasonable. However I remember weakly, that I tried some more 
logical variants first, and they were not accepted by a version of Cabal. 
It's hard to reproduce now.

More information about the cabal-devel mailing list