Problem with cabal-install 0.6 and data-accessor

Duncan Coutts duncan.coutts at
Tue Jun 1 13:52:56 EDT 2010

On Tue, 2010-06-01 at 18:14 +0100, Duncan Coutts wrote:
> > > The tested-with field reads:
> > > 
> > >   Tested-With:      GHC==6.4.1 && ==6.8.2 && ==6.10.4, JHC==0.7.3
> Ohhh. I'd not realised that when we extended the version range parser
> that this would affect the "tested-with" field too. It's obvious in
> retrospect of course.


> I'll also have a go at adding the QA checks so this does not happen
> again.


        $ cabal check
        The following errors will cause portability problems on other
        * Invalid 'tested-with' version range: ghc ==6.4.1 && ==6.8.2 &&
        ==6.10.4. To indicate that you have tested a package with
        multiple different versions of the same compiler use multiple
        entries, for example 'tested-with: GHC==6.10.4, GHC==6.12.3' and
        not 'tested-with: GHC==6.10.4 && ==6.12.3'.
        * The package uses full version-range expressions in a
        'tested-with' field: ghc ==6.4.1 && ==6.8.2 && ==6.10.4. To use
        this new syntax the package needs to specify at least
        'cabal-version: >= 1.8'.
        Hackage would reject this package.

Ross, next time you have a moment for hackage work, we should probably
try building the hackage scripts using the latest Cabal HEAD.

I've not yet fixed the one about excess ()'s which also slipped past the
QA filters.


More information about the cabal-devel mailing list