Problem with cabal-install 0.6 and data-accessor

Henning Thielemann lemming at
Tue Jun 1 05:50:52 EDT 2010

On Tue, 1 Jun 2010, Erik Hesselink wrote:

> On Tue, Jun 1, 2010 at 11:30 AM, Henning Thielemann
>> As far as I understand the problem is only a problem with an older
>> version of Cabal and cabal-install. Is there a reason why you can't
>> update your Cabal to a current version? I still do not feel encouraged
>> to downgrade my package (and others with the Tested-With field).
>> Alternatively you may modify the package privately and install it as
>> say, data-accessor-
> I have upgraded to cabal install 0.8 to solve this problem. However,
> many people still use 0.6, and it is included in distro's as well.
> Additionally, the problem doesn't only occur when trying to install
> data-accessor, but also when installing something else that has
> data-accessor in its dependency tree anywhere, even if cabal-install
> finally decides it doesn't even need to install data-accessor (as it
> did in my case). This means even if you have data-accessor installed
> already, packages that depend on it (or depend on packages that depend
> on it, etc) fail to install.

It did already annoy me a lot, that cabal-install cannot just accept even 
successfully installed packages. But I think this is a problem of 
cabal-install not of data-accessor and other packages that use the 
Tested-With field.

More information about the cabal-devel mailing list