[Hackage] #724: Add getDataDirectory function to Paths_pkgname

Hackage cvs-ghc at haskell.org
Fri Aug 13 10:05:58 EDT 2010

#724: Add getDataDirectory function to Paths_pkgname
  Reporter:  tommd          |        Owner:         
      Type:  enhancement    |       Status:  new    
  Priority:  normal         |    Milestone:         
 Component:  Cabal library  |      Version:
  Severity:  normal         |     Keywords:         
Difficulty:  unknown        |   Ghcversion:         
  Platform:                 |  
 Some libraries and programs have a large number of files.  Instead of
 having explicit knowledge of each file (and instead of using a mutation on
 the result of getDataFilename) there should be a "getDataDirectory" or a

     getDataDirectoryContents = getDataDirectory >>= getDirectoryContents

Ticket URL: <http://hackage.haskell.org/trac/hackage/ticket/724>
Hackage <http://haskell.org/cabal/>
Hackage: Cabal and related projects

More information about the cabal-devel mailing list