[Hackage] #578: Allow installation of distro packages

Hackage trac at galois.com
Wed Sep 23 16:18:11 EDT 2009

#578: Allow installation of distro packages
  Reporter:  bos                 |        Owner:                 
      Type:  enhancement         |       Status:  new            
  Priority:  normal              |    Milestone:  _|_            
 Component:  cabal-install tool  |      Version:                 
  Severity:  normal              |   Resolution:                 
  Keywords:                      |   Difficulty:  project(> week)
Ghcversion:                      |     Platform:                 
Comment (by duncan):

 Replying to [comment:6 nomeata]:

 > From my point of view, I’d already be satisfied if cabal would say "The
 following required packages are also available from your distribution and
 it is recommended to install them before continuing: libghc6-a-dev
 libghc6-b-dev. Do you want to abort now? [Y,n]".

 Unlike apt-get, most cabal commands are not interactive. We prefer to go
 with "Do the right thing". For this issue, surely either the right thing
 is to install the system package or it's not. It's not going to vary on a
 per-package basis. At most it should be a config file preference. Though
 what the default should be I don't know.

Ticket URL: <http://hackage.haskell.org/trac/hackage/ticket/578#comment:8>
Hackage <http://haskell.org/cabal/>
Hackage: Cabal and related projects

More information about the cabal-devel mailing list