[Hackage] #578: Allow installation of distro packages

Hackage trac at galois.com
Wed Sep 23 13:29:17 EDT 2009

#578: Allow installation of distro packages
  Reporter:  bos                 |        Owner:                 
      Type:  enhancement         |       Status:  new            
  Priority:  normal              |    Milestone:  _|_            
 Component:  cabal-install tool  |      Version:                 
  Severity:  normal              |   Resolution:                 
  Keywords:                      |   Difficulty:  project(> week)
Ghcversion:                      |     Platform:                 
Comment (by nomeata):

 Replying to [comment:5 duncan]:
 > The other aspect of the problem of course is the permissions issue.
 Users are typically running cabal under their normal user account. Should
 we attempt to elevate privileges and if so when and how?
 > We already support a --root-cmd=sudo flag which we use with global
 installs performed as the user so that we build as the user and do the
 install step as root.

 From my point of view, I’d already be satisfied if cabal would say "The
 following required packages are also available from your distribution and
 it is recommended to install them before continuing: libghc6-a-dev
 libghc6-b-dev. Do you want to abort now? [Y,n]".

Ticket URL: <http://hackage.haskell.org/trac/hackage/ticket/578#comment:6>
Hackage <http://haskell.org/cabal/>
Hackage: Cabal and related projects

More information about the cabal-devel mailing list