[Hackage] #465: default global install on windows is a problem

Hackage trac at galois.com
Sun Sep 20 13:21:15 EDT 2009

#465: default global install on windows is a problem
  Reporter:  duncan         |        Owner:           
      Type:  defect         |       Status:  new      
  Priority:  normal         |    Milestone:  Cabal-1.8
 Component:  Cabal library  |      Version:  
  Severity:  normal         |   Resolution:           
  Keywords:                 |   Difficulty:  normal   
Ghcversion:  6.8.3          |     Platform:  Windows  
Comment (by duncan):

 I'm convinced the only sensible thing to do is to default to per-user
 installs and to reject --global installs unless we were launched with
 elevated privileges (meaning from within a elevated privileges console

 Providing a way to elevate privileges at just the right time is just too
 hard on Windows.

 See #320 comment 9.

Ticket URL: <http://hackage.haskell.org/trac/hackage/ticket/465#comment:2>
Hackage <http://haskell.org/cabal/>
Hackage: Cabal and related projects

More information about the cabal-devel mailing list