How not to indirectly depend on multiple versions of the same package?

Bas van Dijk v.dijk.bas at
Thu Oct 8 14:24:45 EDT 2009


My usb package fails to build on hackage:

usb depends both on bytestring and text but text also depends on
bytestring. Now, during configuring, a different bytestring version is
choosen than the one text was build with:
Dependency bytestring ==0.9.*: using bytestring-
Dependency text ==0.4.*: using text-0.4
Warning: This package indirectly depends on multiple versions of the same
package. This is highly likely to cause a compile failure.
Dependency bytestring >=0.9 && <1.0: using bytestring-

Is it possible to specify in my cabal file that I depend on the same
bytestring version as to one text was build with?

If not, what is the best way to get my package to build on hackage?



More information about the cabal-devel mailing list