[Hackage] #610: wxcore install fail on Vista

Hackage trac at galois.com
Sun Nov 22 08:41:28 EST 2009

#610: wxcore install fail on Vista
  Reporter:  guest                |        Owner:         
      Type:  defect               |       Status:  new    
  Priority:  normal               |    Milestone:         
 Component:  cabal-install tool   |      Version:
  Severity:  normal               |     Keywords:         
Difficulty:  very hard (<1 week)  |   Ghcversion:         
  Platform:  Windows              |  

 I'm trying to install the wx package onto my Windows Vista machine
 using the command: "cabal install wx" and I am having a problem. The
 problem is with the wxcore package. The error I get is the following:

 setup.exe: wx-config: runGenProcess: does not exist (No such file or
 cabal: Error: some packages failed to install:
 wx- depends on wxcore- which failed to install.
 wxcore- failed during the configure step. The exception was:
 exit: ExitFailure 1

 I have downloaded CYGWIN and run the command from there, but I get the
 exact same error. Any ideas as to what is going on?



Ticket URL: <http://hackage.haskell.org/trac/hackage/ticket/610>
Hackage <http://haskell.org/cabal/>
Hackage: Cabal and related projects

More information about the cabal-devel mailing list