help needed with installing Liskell via cabal-insall

Duncan Coutts duncan.coutts at
Mon Mar 9 08:29:35 EDT 2009

On Fri, 2009-02-27 at 14:16 +0900, Benjamin L.Russell wrote:

> However, the building step still failed, as follows:
> > $ ./Setup.lhs build
> > Preprocessing library liskell-0.1...
> > Setup.lhs: The program happy is required but it could not be found
> However, strangely, "happy" is in fact installed and listed in the
> PATH, as follows:
> > $ which happy
> > /cygdrive/c/Program Files/Haskell/bin/happy

Is this in the normal Windows %PATH%, or just the cygwin $PATH?
ghc/runghc is a normal Windows program so using it to run Setup.hs,
it'll only look at the Windows %PATH% and knows nothing about cygwin.

How did you resolve this? Sounds like you managed to get it building

> I followed his advice, but then ran into the following error in the
> building phase:
> > Main.hs:218:0: parse error (possibly incorrect indentation)
> These are lines 218-19 of my Main.hs file:
> > partition_args :: [String] -> [(String, Maybe Phase)] -> [String]
> > -> ([(String, Maybe Phase)], [String])
> I tried merging line 219 into line 218, but the same error recurred.

This is just an error in the Haskell code.

> In addition, the following error occured during the install phase:

Had you managed to build by that time? ie fixing the above problem? It's
not going to be able to install if it did not build.

> >Setup.lhs: dist\build\liskell\liskell.exe: copyFile: does not exist (No such file or directory)
> This is where I am unable to continue now.
> Does anybody know how to resolve this package installation problem?

Did you get it working in the end? Is there anything from all this that
needs fixing or improving in Cabal?

The current state of the liskell repo build perfectly for me using just

$ cabal install

Admittedly this is on Linux not Windows.


More information about the cabal-devel mailing list