QuickCheck versions and 'cabal install'
Stephen Blackheath [to cabal-devel]
rubbernecking.trumpet.stephen at blacksapphire.com
Wed Jun 10 08:36:22 EDT 2009
I'm getting a lot of this kind of problem now that a new major version
of QuickCheck has come out...
blackh at amentet:~/src/projectx$ cabal install
cabal: dependencies conflict: Crypto-220.127.116.11 requires QuickCheck ==18.104.22.168
QuickCheck-22.214.171.124 was excluded because QuickCheck-126.96.36.199 was selected
QuickCheck-188.8.131.52 was excluded because test-framework-quickcheck2-0.2.2
requires QuickCheck >=184.108.40.206
QuickCheck-220.127.116.11 was excluded because ProjectX-0.1 requires QuickCheck
It isn't practical to fix this properly - That would require lots of
work upgrading quickcheck on all dependent packages. (Crypto-18.104.22.168 is
my hacked version of Crypto-4.2.0 with a closed upper version limit to
prevent it forcing QuickCheck-2.* which won't compile.)
Is there a better solution to this problem?
Should a package maintainer have the right to choose an old version of
QuickCheck, or should cabal's policy force all package maintainers to
upgrade (preferably all on the same day)?
More information about the cabal-devel