checking upper bounds on base

Ross Paterson ross at
Tue Jun 2 06:35:17 EDT 2009

On Tue, Jun 02, 2009 at 10:26:34AM +0100, Duncan Coutts wrote:
> I'd like to get Hackage using the new check for base being bounded
> above. I think it'll make a big difference when it comes to future
> ghc/base upgrades. The last one was papered over by cabal-install
> defaulting to base 3 when the package author did not specify otherwise.
> That will not work forever.
> [...]
> For the practical issues:
> I'll can send announcement to the haskell (+cafe) mailing list
> explaining what people have to do and the rationale.

It's ready to go.  Would you like to send your announcement first?

More information about the cabal-devel mailing list