[Hackage] #439: cabal install: dependency on ghc-prim?

Hackage trac at galois.com
Wed Jan 14 18:03:14 EST 2009

#439: cabal install: dependency on ghc-prim?
  Reporter:  guest               |        Owner:  duncan           
      Type:  defect              |       Status:  closed           
  Priority:  normal              |    Milestone:  cabal-install-0.6
 Component:  cabal-install tool  |      Version:                   
  Severity:  normal              |   Resolution:  fixed            
  Keywords:                      |   Difficulty:  normal           
Ghcversion:  6.8.2               |     Platform:  Linux            
Changes (by duncan):

  * status:  assigned => closed
  * resolution:  => fixed


 Wed Jan 14 14:35:40 GMT 2009  Duncan Coutts <duncan at haskell.org>
   * Don't add installed constraints system packages that are not installed
   In particular fixes a problem (ticket #439) where we required the
   installed version of ghc-prim with compilers that do not have that
   package such as ghc-6.8 and older, hugs, nhc, lhc etc.

Ticket URL: <http://hackage.haskell.org/trac/hackage/ticket/439#comment:4>
Hackage <http://haskell.org/cabal/>
Hackage: Cabal and related projects

More information about the cabal-devel mailing list