[Hackage] #441: cabal update does not update dependent components

Hackage trac at galois.com
Wed Jan 7 13:56:30 EST 2009

#441: cabal update does not update dependent components
  Reporter:  guest               |        Owner:         
      Type:  enhancement         |       Status:  closed 
  Priority:  normal              |    Milestone:         
 Component:  cabal-install tool  |      Version:
  Severity:  normal              |   Resolution:  invalid
  Keywords:                      |   Difficulty:  normal 
Ghcversion:  6.10.1              |     Platform:         
Changes (by duncan):

  * status:  new => closed
  * resolution:  => invalid


 `cabal update` does not upgrade/install packages. It updates the list of
 known packages by downloading the list from the hackage server.

 The `cabal upgrade` command is probably what you are looking for. It
 upgrades all packages to the latest versions. The gentoo equivalent of
 `cabal update` is `emerge --sync` and the equivalent of `cabal upgrade` is
 `emerge -D world`.

Ticket URL: <http://hackage.haskell.org/trac/hackage/ticket/441#comment:1>
Hackage <http://haskell.org/cabal/>
Hackage: Cabal and related projects

More information about the cabal-devel mailing list