[Hackage] #601: cabal setup doesn't respect --prefix

Hackage trac at galois.com
Sat Dec 19 12:40:01 EST 2009

#601: cabal setup doesn't respect --prefix
  Reporter:  zooko          |        Owner:         
      Type:  defect         |       Status:  closed 
  Priority:  normal         |    Milestone:         
 Component:  Cabal library  |      Version:
  Severity:  normal         |   Resolution:  wontfix
  Keywords:                 |   Difficulty:  unknown
Ghcversion:                 |     Platform:         
Comment (by zooko):

 I don't expect you to fix this, but I just want to reiterate that I think
 this is a design flaw.  The use of a package database makes the hackage
 package system incompatible with any principle-of-least-authority-
 respecting installation process, such as GNU stow or Nix.  I know it is
 hard to conceive of an alternative, but there are alternatives, such as
 using the filesystem as your database, such as GNU stow does.

 I wonder how Nix handles hackage issue...

Ticket URL: <http://hackage.haskell.org/trac/hackage/ticket/601#comment:5>
Hackage <http://haskell.org/cabal/>
Hackage: Cabal and related projects

More information about the cabal-devel mailing list