[Hackage] #571: bad error message: "There is no installed version of base"

Hackage trac at galois.com
Sat Aug 1 08:13:28 EDT 2009

#571: bad error message: "There is no installed version of base"
  Reporter:  guest               |        Owner:      
      Type:  defect              |       Status:  new 
  Priority:  low                 |    Milestone:      
 Component:  cabal-install tool  |      Version:  HEAD
  Severity:  minor               |     Keywords:      
Difficulty:  unknown             |   Ghcversion:      
  Platform:                      |  
 Here's a trimmed down version of the problem, demonstrated in a shell
 # ls
 Setup.lhs  u.cabal
 # cat u.cabal
 cabal-version: >= 1.2
 build-type: Simple
 name: u
 version: 0.0

 # cabal install
 Resolving dependencies...
 cabal: There is no installed version of base
 What is wrong? Building and installing the package with Cabal (using
 Setup.lhs) worked fine. And according to ghc-pkg, base was installed.
 After a while I figured out a solution - apparently cabal-install expects
 the package to depend on base:
 # echo '    build-depends: base >= 4 && < 5' >> u.cabal
 # cabal install
 Resolving dependencies...
 Configuring u-0.0...
 Preprocessing library u-0.0...
 Building u-0.0...
 Registering u-0.0...
 Installing library in /opt/ghc-6.10.4/lib/u-0.0/ghc-6.10.4
 Registering u-0.0...
 Is there a good reason for this behaviour?

 (Setting low priority because the vast majority of packages depends on
 base anyway.)

 cabal-install version 0.7                -- darcs head
 using version 1.7.3 of the Cabal library -- ghc's version

 -- int-e

Ticket URL: <http://hackage.haskell.org/trac/hackage/ticket/571>
Hackage <http://haskell.org/cabal/>
Hackage: Cabal and related projects

More information about the cabal-devel mailing list