cabal-install fails with tar checksum error

Alistair Bayley alistair at
Thu Apr 30 10:45:58 EDT 2009

On WinXP. I've uploaded Takusen-0.8.4 to hackage, and thought I'd see
how well cabal-install downloads and installs it.

  cabal install Takusen --flags="sqlite odbc oracle postgres" --reinstall -v3

results in (with some trimming):

In order, the following would be installed:
Takusen-0.8.4 (reinstall)
Takusen-0.8.4 has already been downloaded.
Extracting C:\Documents and Settings\bayleya\Application
Data\cabal\packages\\Takusen\0.8.4\Takusen-0.8.4.tar.gz to
cabal: Error: some packages failed to install:
Takusen-0.8.4 failed while unpacking the package. The exception was:
user error (TAR checksum error)

The uploaded package was created with "darcs dist -d Takusen-0.8.4".
Can I check before uploading that the tar file is valid?

darcs --version gives:
2.0.2 (+ 76 patches)


More information about the cabal-devel mailing list