[Hackage] #359: Warn if package index is older than X days

Hackage trac at galois.com
Fri Sep 26 19:10:52 EDT 2008

#359: Warn if package index is older than X days
  Reporter:  duncan               |        Owner:       
      Type:  defect               |       Status:  new  
  Priority:  normal               |    Milestone:       
 Component:  cabal-install tool   |      Version:  HEAD 
  Severity:  normal               |     Keywords:       
Difficulty:  very easy (<1 hour)  |   Ghcversion:  6.8.2
  Platform:                       |  
 People often trip up with getting older versions of packages than they
 expected because their package index is out of date. This is because
 people have to manually run `cabal update` occasionally. It would be nice
 if this could be done automatically, though we also need to support
 offline operation.

 In the mean time we should at least warn if the package index looks rather

Ticket URL: <http://hackage.haskell.org/trac/hackage/ticket/359>
Hackage <http://haskell.org/cabal/>
Hackage: Cabal and related projects

More information about the cabal-devel mailing list